aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2020-05-08 11:24:06 +0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-08 10:20:01 +0000
commitdab6c137b129aad77c3915facfce1130bef19f5c (patch)
treee4f8bb2c83af63a0504c2325aa3f5f73669cbc39
parent8c7b32c24ed407f11fd616cc6082caf6fa847491 (diff)
community/nodejs-current: upgrade to 14.2.0
-rw-r--r--community/nodejs-current/APKBUILD8
-rw-r--r--community/nodejs-current/link-with-libatomic-on-mips32.patch8
-rw-r--r--community/nodejs-current/unbundle-uv.patch2
3 files changed, 9 insertions, 9 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index 1eae1aa2f6c..147bc98d2c0 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -24,7 +24,7 @@
#
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
-pkgver=14.1.0
+pkgver=14.2.0
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
@@ -95,8 +95,8 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="e6483f0a9edf62a9925b7d803a18131ec1e29067479d6764bbc111df75e1e4de463342f79efc2ce285f7657360ecabe951054c196896835285fa3244648601a4 node-v14.1.0.tar.gz
+sha512sums="a13fe3cc94a14b3d2a6fcb8511e62e613b8467da7d53915e6454ca56012bb9c143e67730507a92cb1bb54ff5c2e1f388adaf220828a8246cddc5c08d8642c3ef node-v14.2.0.tar.gz
940cc90aaa77a531cde13e31918a9978f9478936c3851038bcdf2869e64de03ce84dec5a46519469a90a8ba2853226825452d23d9347752abdbe04e944c083eb dont-run-gyp-files-for-bundled-deps.patch
-fd7722bc6bd257e3bc684db2b12edf35fcdff1093af2b7afed3210f527d103aca1843cfc4524ea43d329c9efc8c8e9e3045590d7550b99abdef3ba84b3786984 link-with-libatomic-on-mips32.patch
+65df7eeadbdfc015185260c0e24f3206714e4d2aacceef742d078a4f8bae386b2867e0f7f3b8c2eac47180cb10a8e14b71a36a23bb74ed6a95eecbaf76897e0c link-with-libatomic-on-mips32.patch
ace818285ff0b868f17be64db7c7b77b314ba370fda6bac640d56bf18322a54fa015206a3e1adefa1d78ef66b597eebf10c28d6549005cd7e58f60a37c38b741 elf.patch
-a4e1e7bd4f32ee30ebd319ac0c2fc751166f8fdd27f491709003dfebda51cbece9412630f0b98f0b85253ccc4f066c82997ad68abb9b87dc0b47c24d09a0643a unbundle-uv.patch"
+6b06f819a026999e3a01bee09401004376e8c1fe19541a6f508557e73fbbb5b9d433cf8130a99230c7d04513715dff898f6004809e1ce7d0c01287312e468a5a unbundle-uv.patch"
diff --git a/community/nodejs-current/link-with-libatomic-on-mips32.patch b/community/nodejs-current/link-with-libatomic-on-mips32.patch
index 358d52d082a..b082c4139a8 100644
--- a/community/nodejs-current/link-with-libatomic-on-mips32.patch
+++ b/community/nodejs-current/link-with-libatomic-on-mips32.patch
@@ -14,7 +14,7 @@
'defines': ['USING_V8_PLATFORM_SHARED'],
--- a/node.gyp
+++ b/node.gyp
-@@ -375,6 +375,11 @@
+@@ -376,6 +376,11 @@
'msvs_disabled_warnings!': [4244],
'conditions': [
@@ -23,6 +23,6 @@
+ 'libraries': [ '-latomic' ],
+ },
+ }],
- [ 'node_intermediate_lib_type=="static_library" and '
- 'node_shared=="true" and OS=="aix"', {
- # For AIX, shared lib is linked by static lib and .exp. In the
+ [ 'error_on_warn=="true"', {
+ 'cflags': ['-Werror'],
+ }],
diff --git a/community/nodejs-current/unbundle-uv.patch b/community/nodejs-current/unbundle-uv.patch
index 38025e8c7e8..9c600454843 100644
--- a/community/nodejs-current/unbundle-uv.patch
+++ b/community/nodejs-current/unbundle-uv.patch
@@ -1,6 +1,6 @@
--- a/deps/uvwasi/uvwasi.gyp
+++ b/deps/uvwasi/uvwasi.gyp
-@@ -16,7 +16,6 @@
+@@ -17,7 +17,6 @@
'src/wasi_rights.c',
],
'dependencies': [