aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2017-09-30 16:14:51 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-10-01 07:42:52 +0000
commitdab737e62f7c4070ea3ee7518ff81b3bfdc821c7 (patch)
treefe91fec85e304e8e24a5985e0e50633a59bf17d5
parent4820cd50c86ea468e192675bee179adde0834800 (diff)
community/py-jsonschema: upgrade to 2.6.0
-rw-r--r--community/py-jsonschema/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/community/py-jsonschema/APKBUILD b/community/py-jsonschema/APKBUILD
index af27997f403..594177873f4 100644
--- a/community/py-jsonschema/APKBUILD
+++ b/community/py-jsonschema/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py-jsonschema
_pkgname=jsonschema
-pkgver=2.5.1
-pkgrel=5
+pkgver=2.6.0
+pkgrel=0
pkgdesc="An implementation of JSON Schema validation for Python"
url="http://github.com/Julian/jsonschema"
arch="noarch"
@@ -15,8 +15,8 @@ builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
package() {
@@ -41,13 +41,12 @@ _py() {
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir" || return 1
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
# Add version suffix to executable files.
local path; for path in "$subpkgdir"/usr/bin/*; do
mv "$path" "$path-$pyver" || return 1
done
}
-md5sums="374e848fdb69a3ce8b7e778b47c30640 jsonschema-2.5.1.tar.gz"
-sha256sums="36673ac378feed3daa5956276a829699056523d7961027911f064b52255ead41 jsonschema-2.5.1.tar.gz"
-sha512sums="9e8f6ce16504b7ae7ef1ceb44ecb07eab85923e40967bd8e502b9fa779e772b547db90f56ca951d06591b951e7240db1071e909ac75543d42f6f2495f6de3298 jsonschema-2.5.1.tar.gz"
+
+sha512sums="03f916abd023b32fbe60f91718d6f2f94d8834bd1bd8ec85ab02f591a145161275c2cde25b037c4d2e94703b870159feb776d3556f011e4c394d2e20ab897b0b jsonschema-2.6.0.tar.gz"