aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-17 14:16:07 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-17 14:32:04 +0000
commitdbe6ef6e13bb51a4de731a69878ba1e14472976d (patch)
tree5255d07050fc6ad45659f088a791bc8078d34fcc
parentb93e1faa9d05ff2200964aaea546237b4e479a73 (diff)
community/py-sip: upgrade to 4.19.2
-rw-r--r--community/py-sip/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/community/py-sip/APKBUILD b/community/py-sip/APKBUILD
index baad000d656..d7cf66d8293 100644
--- a/community/py-sip/APKBUILD
+++ b/community/py-sip/APKBUILD
@@ -2,22 +2,20 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py-sip
_pkgname=sip
-pkgver=4.18.1
+pkgver=4.19.2
pkgrel=0
pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
url="http://www.riverbankcomputing.com/software/sip/"
arch="all"
license="custom:sip"
-depends=""
-depends_dev=""
makedepends="python2-dev"
-install=""
subpackages="$pkgname-dev"
source="http://sourceforge.net/projects/pyqt/files/sip/sip-$pkgver/sip-$pkgver.tar.gz"
-_builddir="$srcdir"/$_pkgname-$pkgver
+builddir="$srcdir"/$_pkgname-$pkgver
+
build() {
- cd "$_builddir"
+ cd "$builddir"
local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
python configure.py
make CC="${CC:-gcc}" \
@@ -28,11 +26,9 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/custom/${pkgname}/LICENSE
}
-md5sums="9d664c33e8d0eabf1238a7ff44a399e9 sip-4.18.1.tar.gz"
-sha256sums="9bce7a2dbf7f105bf68ad1bab58eebc0ce33087ec40396da756463f086ffa290 sip-4.18.1.tar.gz"
-sha512sums="c4277fa113bf5e28d8a19388f160456654e4ccbbc2adc1209677e95e1efad427ce641ef09875ec0a59e555578986671261dd4c3ac52c673b5803f188fc311222 sip-4.18.1.tar.gz"
+sha512sums="6f14f387a899130cf15820d2b58d937d134a2eefd53c65a82af060e88a6ca039442b21f822880c4a3742d6f26328853a552239873c55d7b22de62a6cc5037b3e sip-4.19.2.tar.gz"