aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-08-14 17:58:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-08-15 05:32:05 +0000
commitdcca58ea4cd725eb1836df671cd4fbd1b0fd023f (patch)
tree9360b8c448182a0f9eab2cdec60118d7bca5d455
parent828594101fa32bd6f6a22ea24735639f7d9c6459 (diff)
community/py3-treq: enable testsuite
-rw-r--r--community/py3-treq/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/py3-treq/APKBUILD b/community/py3-treq/APKBUILD
index 0b7c4253299..aec7983e672 100644
--- a/community/py3-treq/APKBUILD
+++ b/community/py3-treq/APKBUILD
@@ -4,12 +4,12 @@ pkgname=py3-treq
pkgver=20.4.1
pkgrel=0
pkgdesc="py3-requests-like API build on top of Twisted's HTTP client"
-options="!check" # Requires unpackaged httpbin
url="https://github.com/twisted/treq"
arch="noarch"
license="MIT"
depends="python3 py3-incremental py3-requests py3-six py3-twisted py3-attrs"
makedepends="py3-setuptools"
+checkdepends="py3-httpbin py3-openssl py3-pytest py3-mock py3-service_identity"
source="$pkgname-$pkgver.tar.gz::https://github.com/twisted/treq/archive/release-$pkgver.tar.gz"
builddir="$srcdir/treq-release-$pkgver"
@@ -17,6 +17,11 @@ build() {
python3 setup.py build
}
+check() {
+ rm -f src/treq/test/test_treq_integration.py
+ python3 -m pytest
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}