aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-29 09:39:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-29 09:39:56 +0000
commitdd02ab6587fae49758cfbb245f024825ba8fe201 (patch)
tree70e293fe5a4b73c53872475b818812304ebac86d
parent49a8e07ed854de0916de7f9b37ec1d672e32906d (diff)
community/stress-ng: fix build with new musl and old kernel-headers
-rw-r--r--community/stress-ng/APKBUILD6
-rw-r--r--community/stress-ng/fix-kernel-header-detection.patch14
2 files changed, 18 insertions, 2 deletions
diff --git a/community/stress-ng/APKBUILD b/community/stress-ng/APKBUILD
index aa682452e3a..594e0773fb6 100644
--- a/community/stress-ng/APKBUILD
+++ b/community/stress-ng/APKBUILD
@@ -16,7 +16,8 @@ makedepends="
zlib-dev
"
subpackages="$pkgname-doc"
-source="https://kernel.ubuntu.com/~cking/tarballs/stress-ng/stress-ng-$pkgver.tar.xz"
+source="https://kernel.ubuntu.com/~cking/tarballs/stress-ng/stress-ng-$pkgver.tar.xz
+ fix-kernel-header-detection.patch"
build() {
make
@@ -27,4 +28,5 @@ package() {
JOBDIR="/usr/share/doc/$pkgname/example-jobs/" install
}
-sha512sums="97da711511d006ae309817b8a0d350069f5f70e453b6cd5f2be4f1b828e513758e3a891ac02358c9729e62c7be6497170599ef3474bb295f98c73a2fb12e66af stress-ng-0.10.06.tar.xz"
+sha512sums="97da711511d006ae309817b8a0d350069f5f70e453b6cd5f2be4f1b828e513758e3a891ac02358c9729e62c7be6497170599ef3474bb295f98c73a2fb12e66af stress-ng-0.10.06.tar.xz
+d444d2f0bc1969b133f8a915592079efdb049f08a4e13e4cfa078dc856015bbeb499abb47817b088a935096fe28c748d328f6907138eea6ec47f51efcd0d6889 fix-kernel-header-detection.patch"
diff --git a/community/stress-ng/fix-kernel-header-detection.patch b/community/stress-ng/fix-kernel-header-detection.patch
new file mode 100644
index 00000000000..f93961e2b3e
--- /dev/null
+++ b/community/stress-ng/fix-kernel-header-detection.patch
@@ -0,0 +1,14 @@
+diff --git a/stress-ramfs.c b/stress-ramfs.c
+index 09d89a9..f02ce28 100644
+--- a/stress-ramfs.c
++++ b/stress-ramfs.c
+@@ -191,7 +191,8 @@ static int stress_ramfs_child(const args_t *args)
+ #if defined(__NR_fsopen) && \
+ defined(__NR_fsmount) && \
+ defined(__NR_fsconfig) && \
+- defined(__NR_move_mount)
++ defined(__NR_move_mount) && \
++ defined(FSCONFIG_SET_STRING)
+ /*
+ * Use the new Linux 5.2 mount system calls
+ */