aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2022-01-13 15:23:55 +0100
committerBart Ribbers <bribbers@disroot.org>2022-01-13 15:23:55 +0100
commitdd24cfd85bde716ae47f30907d59f2c3e66badef (patch)
tree4c7d23a7ec12be0db9483964ba8e38f607174e51
parentc5cf14eddbff8e20ef3e852f4e1bcd16293b8294 (diff)
community/plasma-wayland-protocols: upgrade to 0.6.0
-rw-r--r--community/plasma-wayland-protocols/0001-Add-support-for-Primary-Outputs.patch120
-rw-r--r--community/plasma-wayland-protocols/APKBUILD11
2 files changed, 4 insertions, 127 deletions
diff --git a/community/plasma-wayland-protocols/0001-Add-support-for-Primary-Outputs.patch b/community/plasma-wayland-protocols/0001-Add-support-for-Primary-Outputs.patch
deleted file mode 100644
index 8b3298edc59..00000000000
--- a/community/plasma-wayland-protocols/0001-Add-support-for-Primary-Outputs.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-From fcc237f113c596abfc4e95ddbe67dde5782d13f1 Mon Sep 17 00:00:00 2001
-From: Aleix Pol <aleixpol@kde.org>
-Date: Thu, 28 Oct 2021 15:35:09 +0200
-Subject: [PATCH] Add support for Primary Outputs
-
-Introduce a kde_primary_output_v1 protocol to query
-Changes kde_output_configuration_v2 to be able to change which is the
-new
-primary output.
----
- src/CMakeLists.txt | 1 +
- src/protocols/kde-output-device-v2.xml | 9 ++++++++-
- src/protocols/kde-output-management-v2.xml | 8 ++++++--
- src/protocols/kde-primary-output-v1.xml | 22 ++++++++++++++++++++++
- 4 files changed, 37 insertions(+), 3 deletions(-)
- create mode 100644 src/protocols/kde-primary-output-v1.xml
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index c6433f92..9e5c96eb 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -9,6 +9,7 @@ install(FILES
- protocols/keystate.xml
- protocols/outputdevice.xml
- protocols/output-management.xml
-+ protocols/kde-primary-output-v1.xml
- protocols/kde-output-device-v2.xml
- protocols/kde-output-management-v2.xml
- protocols/plasma-shell.xml
-diff --git a/src/protocols/kde-output-device-v2.xml b/src/protocols/kde-output-device-v2.xml
-index fb6b9b02..f2bb1a3d 100644
---- a/src/protocols/kde-output-device-v2.xml
-+++ b/src/protocols/kde-output-device-v2.xml
-@@ -11,7 +11,7 @@
- ]]></copyright>
-
-
-- <interface name="kde_output_device_v2" version="1">
-+ <interface name="kde_output_device_v2" version="2">
- <description summary="output configuration representation">
- An output device describes a display device available to the compositor.
- output_device is similar to wl_output, but focuses on output
-@@ -266,6 +266,13 @@
- </description>
- <arg name="rgb_range" type="uint" enum="rgb_range"/>
- </event>
-+
-+ <event name="name" since="2">
-+ <description summary="Output's name">
-+ Name of the output, it's useful to cross-reference to an zxdg_output_v1 and ultimately QScreen
-+ </description>
-+ <arg name="name" type="string"/>
-+ </event>
-
- </interface>
-
-diff --git a/src/protocols/kde-output-management-v2.xml b/src/protocols/kde-output-management-v2.xml
-index 58f59f97..605747fb 100644
---- a/src/protocols/kde-output-management-v2.xml
-+++ b/src/protocols/kde-output-management-v2.xml
-@@ -10,7 +10,7 @@
- SPDX-License-Identifier: MIT-CMU
- ]]></copyright>
-
--<interface name="kde_output_management_v2" version="1">
-+<interface name="kde_output_management_v2" version="2">
- <description summary="configuration of server outputs through clients">
- This interface enables clients to set properties of output devices for screen
- configuration purposes via the server. To this end output devices are referenced
-@@ -62,7 +62,7 @@
-
- </interface>
-
--<interface name="kde_output_configuration_v2" version="1">
-+<interface name="kde_output_configuration_v2" version="2">
- <description summary="configure single output devices">
- outputconfiguration is a client-specific resource that can be used to ask
- the server to apply changes to available output devices.
-@@ -192,6 +192,10 @@
- <arg name="rgb_range" type="uint" enum="rgb_range"/>
- </request>
-
-+ <request name="set_primary_output" since="2">
-+ <description summary="Select which primary output to use" />
-+ <arg name="output" type="object" interface="kde_output_device_v2" allow-null="false"/>
-+ </request>
- </interface>
-
- </protocol>
-diff --git a/src/protocols/kde-primary-output-v1.xml b/src/protocols/kde-primary-output-v1.xml
-new file mode 100644
-index 00000000..7da58eee
---- /dev/null
-+++ b/src/protocols/kde-primary-output-v1.xml
-@@ -0,0 +1,22 @@
-+<?xml version="1.0" encoding="UTF-8"?>
-+<protocol name="kde_primary_output_v1">
-+ <copyright><![CDATA[
-+ SPDX-FileCopyrightText: 2021 Aleix Pol Gonzalez <aleixpol@kde.org>
-+
-+ SPDX-License-Identifier: MIT-CMU
-+ ]]></copyright>
-+
-+<interface name="kde_primary_output_v1" version="1">
-+ <description summary="expose which is the primary display">
-+ Protocol for telling which is the primary display among the selection of enabled outputs.
-+ </description>
-+
-+ <event name="primary_output">
-+ <description summary="Provide the current primary output's name">
-+ Specifies which output is the primary one identified by their uuid. See kde_output_device_v2 uuid event for more information about it.
-+ </description>
-+ <arg name="output_name" type="string" summary="the name of the output"/>
-+ </event>
-+</interface>
-+
-+</protocol>
---
-GitLab
-
diff --git a/community/plasma-wayland-protocols/APKBUILD b/community/plasma-wayland-protocols/APKBUILD
index 4818aaacb54..812660bc403 100644
--- a/community/plasma-wayland-protocols/APKBUILD
+++ b/community/plasma-wayland-protocols/APKBUILD
@@ -1,16 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-wayland-protocols
-pkgver=1.5.0
-pkgrel=1
+pkgver=1.6.0
+pkgrel=0
pkgdesc="Plasma Specific Protocols for Wayland"
arch="noarch !armhf" # armhf blocked by extra-cmake-modules
url="https://www.kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-only"
makedepends="extra-cmake-modules"
-source="https://download.kde.org/stable/plasma-wayland-protocols/plasma-wayland-protocols-$pkgver.tar.xz
- 0001-Add-support-for-Primary-Outputs.patch
- "
+source="https://download.kde.org/stable/plasma-wayland-protocols/plasma-wayland-protocols-$pkgver.tar.xz"
options="!check" # No tests
build() {
@@ -25,6 +23,5 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-bec83ee401e71fff3c5a38768034b0dfc1dd191af634b9ffa765bf86d9c14143abc2c5abd743dc53cc6c0aac1dbbf79104683c9ff5c6d880b03e71399806a6d7 plasma-wayland-protocols-1.5.0.tar.xz
-03154c76a85fc1cb4ed6fe260f1c3966ab93ce96d116a270d7a78ed0cfb06c810a828eb4916ad4d1ea014018d571e7ea12314c3fe1d09b603108afd625ab89d5 0001-Add-support-for-Primary-Outputs.patch
+a9306d30032c46e8046ffbc8713e1afab732ee48a43922d0091cff25f0aaf407bee6fd08c333d9a83d064b903ebd1699d7d0ceadfe8b939ffd4d5e2129c22cf8 plasma-wayland-protocols-1.6.0.tar.xz
"