aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-12-26 07:59:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-12-26 07:59:58 +0000
commitde144ef397445506f115a13d95125d09a0839e85 (patch)
treefa8c514ff26eec57733be24d0e31d719e729f23d
parentd013960220ac22969192c941a7ab25c0333e37f2 (diff)
community/ruby-rmagick: backport fix for MPEG rename
https://github.com/rmagick/rmagick/pull/1231#issuecomment-702759185
-rw-r--r--community/ruby-rmagick/APKBUILD6
-rw-r--r--community/ruby-rmagick/RSpec-Remove-MPEG-format-because-it-was-renamed.patch23
2 files changed, 27 insertions, 2 deletions
diff --git a/community/ruby-rmagick/APKBUILD b/community/ruby-rmagick/APKBUILD
index 382db22f610..941fade15ae 100644
--- a/community/ruby-rmagick/APKBUILD
+++ b/community/ruby-rmagick/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ruby-rmagick
_gemname=rmagick
pkgver=4.1.2
_pkgver=${pkgver//./-}
-pkgrel=0
+pkgrel=1
pkgdesc="Ruby bindings for ImageMagick"
url="https://github.com/rmagick/rmagick"
arch="all !mips64" # testsuite fails on mips64
@@ -16,6 +16,7 @@ source="https://github.com/rmagick/rmagick/archive/RMagick_$_pkgver.tar.gz
gemspec.patch
spec-drop-pry.patch
dont-test-webp.patch
+ RSpec-Remove-MPEG-format-because-it-was-renamed.patch
"
builddir="$srcdir/rmagick-RMagick_$_pkgver"
@@ -50,4 +51,5 @@ package() {
sha512sums="671ce8ef0d2387d6f0091a7a7a79a5ee9a5c5cd9340f5d29b4a35227c2293eae5e0e5c9ef16a83dc24ed0cb59cc7258427f8880484f7bb49dfaccb00d280e2b4 RMagick_4-1-2.tar.gz
9a5dccceb069d0b274256c181335ac92037d0def3b3ed4e087f1eec1f7e9a9d07f9105bec87f732828c3bdff96b7032ffd696d6b9b4941748b0b64315d11d253 gemspec.patch
c6fa08e68a4cd94bdcee2e83144845862a49c86fdbaccd500af6459e09092f0a7bb03352875e73a20a9fc5474f4376df378aea6a61415fdf249b4e9de5c95266 spec-drop-pry.patch
-5eeea508d44f2c9679fe4fe3d5b9a51470f8022537f5822f85c95dbd4d78149c2cada763f0bdf3e86523770b0b758117a6d216b240c92f54253905c19d38d064 dont-test-webp.patch"
+5eeea508d44f2c9679fe4fe3d5b9a51470f8022537f5822f85c95dbd4d78149c2cada763f0bdf3e86523770b0b758117a6d216b240c92f54253905c19d38d064 dont-test-webp.patch
+51b75632302861aa99377c73f27cc7acf82866d40714004c817015c219044a5032f05f7bd715bf00d70fa4e385522dac9f7eb579696f2c050e9467088d1d9716 RSpec-Remove-MPEG-format-because-it-was-renamed.patch"
diff --git a/community/ruby-rmagick/RSpec-Remove-MPEG-format-because-it-was-renamed.patch b/community/ruby-rmagick/RSpec-Remove-MPEG-format-because-it-was-renamed.patch
new file mode 100644
index 00000000000..afc8c14929d
--- /dev/null
+++ b/community/ruby-rmagick/RSpec-Remove-MPEG-format-because-it-was-renamed.patch
@@ -0,0 +1,23 @@
+From 2dff3ba3417cd8d733e4e065bbaedc38cb74ea31 Mon Sep 17 00:00:00 2001
+From: Watson <watson1978@gmail.com>
+Date: Sun, 4 Oct 2020 18:30:46 +0900
+Subject: [PATCH] RSpec: Remove MPEG format because it was renamed at 6.9.11-31
+ and 7.0.10-31 (#1238)
+
+See: https://github.com/rmagick/rmagick/pull/1231#issuecomment-702759185
+---
+ spec/rmagick/image/format_spec.rb | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/spec/rmagick/image/format_spec.rb b/spec/rmagick/image/format_spec.rb
+index 118968e55..c385569a2 100644
+--- a/spec/rmagick/image/format_spec.rb
++++ b/spec/rmagick/image/format_spec.rb
+@@ -8,7 +8,6 @@
+ expect { image.format = 'JPG' }.not_to raise_error
+ expect { image.format = 'TIFF' }.not_to raise_error
+ expect { image.format = 'MIFF' }.not_to raise_error
+- expect { image.format = 'MPEG' }.not_to raise_error
+ v = $VERBOSE
+ $VERBOSE = nil
+ expect { image.format = 'shit' }.to raise_error(ArgumentError)