aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-10-13 02:13:44 +0000
committerpsykose <alice@ayaya.dev>2022-10-13 04:13:44 +0200
commitde2fcb8a348240ed779da741770a2d45635d6b6d (patch)
tree6a0dd55c4b4d53e58bf728e7b8d9fc8106935ae3
parentb7e7d8c936dfb0f091546ff9175907f870b7dd6e (diff)
main/spice: upgrade to 0.15.1
-rw-r--r--main/spice/APKBUILD35
-rw-r--r--main/spice/failing-tests.patch36
-rw-r--r--main/spice/fix-build.patch6
-rw-r--r--main/spice/python-module-check.patch37
4 files changed, 33 insertions, 81 deletions
diff --git a/main/spice/APKBUILD b/main/spice/APKBUILD
index 6ce812858d5..02d9ec28c26 100644
--- a/main/spice/APKBUILD
+++ b/main/spice/APKBUILD
@@ -1,35 +1,34 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice
-pkgver=0.15.0
-pkgrel=3
+pkgver=0.15.1
+pkgrel=0
pkgdesc="Implements the SPICE protocol"
url="http://www.spice-space.org/"
arch="all"
license="LGPL-2.0-or-later"
makedepends="
- meson
- spice-protocol
- glib-dev
+ cyrus-sasl-dev
gdk-pixbuf-dev
- pixman-dev
- openssl-dev>3
+ glib-dev
+ gst-plugins-base-dev
+ gstreamer-dev
libjpeg-turbo-dev
- zlib-dev
+ lz4-dev
+ meson
+ openssl-dev>3
opus-dev
- gstreamer-dev
- gst-plugins-base-dev
orc-dev
- lz4-dev
- cyrus-sasl-dev
- py3-six
+ pixman-dev
py3-parsing
+ py3-six
+ spice-protocol
+ zlib-dev
"
subpackages="$pkgname-dev $pkgname-server"
source="https://www.spice-space.org/download/releases/spice-server/spice-$pkgver.tar.bz2
failing-tests.patch
fix-build.patch
- python-module-check.patch
"
# secfixes:
@@ -49,6 +48,7 @@ source="https://www.spice-space.org/download/releases/spice-server/spice-$pkgver
build() {
abuild-meson \
+ -Db_lto=true \
-Dgstreamer=1.0 \
-Dlz4=true \
-Dsasl=true \
@@ -73,8 +73,7 @@ server() {
}
sha512sums="
-0a776d191c395ce1f7ebbbac47956a00a2765327d3127aeca6e232bd56fd4ccd28750ae1599eb6eb2909ac909cda517d5511faa631166db16b8b75bd4e7b86d9 spice-0.15.0.tar.bz2
-96f3f4e8d7d0582bf6ac23649cf90e4f23a8670bf251308fdc4736bcc243c977b50731b16047256a981259e3928e48e2b410624530748bcd285b3187f35fed88 failing-tests.patch
-b61ae910c08e26c7788682f6b5df8190c9db7802858f9ca05093bb1bafd226adc2f16382721e4f63cbc09b7196f9ac967d0175c1e16253028e94fa27372ab8e6 fix-build.patch
-5bddddcb3e37b79354ba4c03157c6a1cb8d9952a700128fea83f3d32a9ac86ba3de96aa9c68f8c80ff2ca5658318630c889b9bbc87ba2e2889c5eb94b5fec16e python-module-check.patch
+362ab2f0b483911830693834515e1d331a6b929c5c63fd4522e843c42bbb7d8a52510d60f5f17d175dd2617c9621630f6a81f3ff7dce11dc28e6fb135e60fa86 spice-0.15.1.tar.bz2
+4fe7665ba7ef63d92570a870eb74f907e9d68f465e6607de7f16233c1d4cd209f390b3d51e2f9da1dd2365027e0402c042396d049d8e78e1eebdd3f5c56686d5 failing-tests.patch
+daba811f9209f9c99ae30eff42068858f3c366fa824e795357ccbb3ae232d45aa305b2da7f48b8f4b2e3494d9eaffcc613e84963603dec2886b06a1d22686ce2 fix-build.patch
"
diff --git a/main/spice/failing-tests.patch b/main/spice/failing-tests.patch
index a32e0341489..413d7fd387d 100644
--- a/main/spice/failing-tests.patch
+++ b/main/spice/failing-tests.patch
@@ -1,8 +1,18 @@
diff --git a/server/tests/meson.build b/server/tests/meson.build
-index 09ba0f2..9833746 100644
+index 1ae7d37..e93334e 100644
--- a/server/tests/meson.build
+++ b/server/tests/meson.build
-@@ -52,7 +52,6 @@
+@@ -42,17 +42,14 @@ tests = [
+ ['test-dispatcher', true, 'cpp'],
+ ['test-options', true],
+ ['test-stat', true],
+- ['test-agent-msg-filter', true],
+ ['test-loop', true],
+ ['test-qxl-parsing', true, 'cpp'],
+- ['test-leaks', true],
+ ['test-vdagent', true],
+ ['test-fail-on-null-core-interface', true],
+ ['test-empty-success', true],
['test-channel', true, 'cpp'],
['test-stream-device', true, 'cpp'],
['test-set-ticket', true],
@@ -10,7 +20,7 @@ index 09ba0f2..9833746 100644
['test-record', true],
['test-display-no-ssl', false],
['test-display-streaming', false],
-@@ -62,10 +61,6 @@
+@@ -62,10 +59,6 @@ tests = [
['test-display-width-stride', false],
]
@@ -21,23 +31,3 @@ index 09ba0f2..9833746 100644
if spice_server_has_smartcard == true
tests += [['test-smartcard', true, 'cpp']]
endif
---- a/server/tests/meson.build
-+++ b/server/tests/meson.build
-@@ -42,7 +42,6 @@
- ['test-dispatcher', true, 'cpp'],
- ['test-options', true],
- ['test-stat', true],
-- ['test-agent-msg-filter', true],
- ['test-loop', true],
- ['test-qxl-parsing', true],
- ['test-leaks', true],
---- a/server/tests/meson.build
-+++ b/server/tests/meson.build
-@@ -44,7 +44,6 @@
- ['test-stat', true],
- ['test-loop', true],
- ['test-qxl-parsing', true],
-- ['test-leaks', true],
- ['test-vdagent', true],
- ['test-fail-on-null-core-interface', true],
- ['test-empty-success', true],
diff --git a/main/spice/fix-build.patch b/main/spice/fix-build.patch
index 76c2c3189ca..0d599fdf2a5 100644
--- a/main/spice/fix-build.patch
+++ b/main/spice/fix-build.patch
@@ -1,7 +1,7 @@
-diff --git a/doxygen.sh a/doxygen.sh
+diff --git a/build-aux/meson-dist b/build-aux/meson-dist
new file mode 100755
-index 0000000000..1a2485251c
+index 0000000..1a24852
--- /dev/null
-+++ a/doxygen.sh
++++ b/build-aux/meson-dist
@@ -0,0 +1 @@
+#!/bin/sh
diff --git a/main/spice/python-module-check.patch b/main/spice/python-module-check.patch
deleted file mode 100644
index a41ecf96b8b..00000000000
--- a/main/spice/python-module-check.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Patch-Source: https://gitlab.freedesktop.org/spice/spice-common/-/commit/a7b5474bf808934cf0ee1107a58d5f4d97b9afbf
-From a7b5474bf808934cf0ee1107a58d5f4d97b9afbf Mon Sep 17 00:00:00 2001
-From: Frediano Ziglio <freddy77@gmail.com>
-Date: Thu, 28 Oct 2021 16:45:34 +0100
-Subject: [PATCH] build: Correctly check for Python modules
-
-Currently using Meson the command "python -m <MODULE_NAME>" is
-run. However this command instead of trying to import the module
-tried to execute it as a script failing for the updated pyparsing
-with:
-
- /usr/bin/python3: No module named pyparsing.__main__; 'pyparsing' is a package and cannot be directly executed
-
-So instead use "python -c 'import <MODULE_NAME>".
-Autoconf is already using that command (see m4/ax_python_module.m4).
-
-Signed-off-by: Frediano Ziglio <freddy77@gmail.com>
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index aff6243..eeccecd 100644
---- a/subprojects/spice-common/meson.build
-+++ b/subprojects/spice-common/meson.build
-@@ -132,7 +132,7 @@ if spice_common_generate_client_code or spice_common_generate_server_code
- if get_option('python-checks')
- foreach module : ['six', 'pyparsing']
- message('Checking for python module @0@'.format(module))
-- cmd = run_command(python, '-m', module)
-+ cmd = run_command(python, '-c', 'import @0@'.format(module))
- if cmd.returncode() != 0
- error('Python module @0@ not found'.format(module))
- endif
---
-GitLab
-