aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-09-01 00:15:52 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-09-07 11:37:50 +0200
commitdf7a2b6e09b4550b5d172a32de20df87fde97e2c (patch)
treee7e0037b45735abcf95fddb8703d268a196783a1
parenta05a641f93693740c9f628db248be6b3e2de5a2e (diff)
downloadaports-df7a2b6e09b4550b5d172a32de20df87fde97e2c.tar.gz
aports-df7a2b6e09b4550b5d172a32de20df87fde97e2c.tar.bz2
aports-df7a2b6e09b4550b5d172a32de20df87fde97e2c.tar.xz
community/totem-pl-parser: use abuild-meson & meson compile/test/install
-rw-r--r--community/totem-pl-parser/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/community/totem-pl-parser/APKBUILD b/community/totem-pl-parser/APKBUILD
index 69d0cddf962..8ff804a3de3 100644
--- a/community/totem-pl-parser/APKBUILD
+++ b/community/totem-pl-parser/APKBUILD
@@ -14,25 +14,20 @@ subpackages="$pkgname-dev $pkgname-lang"
source="https://download.gnome.org/sources/totem-pl-parser/${pkgver%.*}/totem-pl-parser-$pkgver.tar.xz"
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
+ abuild-meson \
-Denable-libarchive=yes \
-Denable-libgcrypt=yes \
-Dintrospection=true \
build
- ninja -C build
+ meson compile ${JOBS:+-j ${JOBS}} -C build
}
check() {
- ninja -C build test
+ meson test --no-rebuild -v -C build
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C build
}
sha512sums="ce110d92f60da328272a8135a57ba60785ea4bca1fde3703a734969e7ba5b382ef19dc3b8930a5641d8f8effabf627f7e9b2727ee94e69e6144e0f085079e14d totem-pl-parser-3.26.5.tar.xz"