aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-04-11 20:04:08 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-04-11 20:08:59 +0000
commite00ba8b6f493c6e7d1434ec2a0682a5cb302e3bb (patch)
tree09e3c925815ef90c35db0962cebe4cf0ed498a5f
parent9985636a66bfcce257ab407009c3b1a71133ea35 (diff)
community/py3-gitlab: add missing dependency
Before this change: $ sudo apk add py3-gitlab ✂ $ gitlab --version Traceback (most recent call last): File "/usr/bin/gitlab", line 6, in <module> from pkg_resources import load_entry_point ModuleNotFoundError: No module named 'pkg_resources' After this change: $ sudo apk add py3-gitlab ✂ $ gitlab --version 2.2.0 The commands above were run inside docker-abuild using `dabuild sh`. The change is required because `/usr/bin/gitlab` includes the line: from pkg_resources import load_entry_point That means that py3-setuptools is required at runtime: $ python3 -c 'import pkg_resources; print(pkg_resources.__file__)' /usr/lib/python3.8/site-packages/pkg_resources/__init__.py $ apk info -q -W /usr/lib/python3.8/site-packages/pkg_resources/__init__.py py3-setuptools
-rw-r--r--community/py3-gitlab/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/community/py3-gitlab/APKBUILD b/community/py3-gitlab/APKBUILD
index 41976174d22..27e420c48ad 100644
--- a/community/py3-gitlab/APKBUILD
+++ b/community/py3-gitlab/APKBUILD
@@ -3,13 +3,12 @@
pkgname=py3-gitlab
_pkgname=python-gitlab
pkgver=2.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="v4 GitLab API compliant library and cmdline tool"
url="https://github.com/python-gitlab/python-gitlab"
arch="noarch"
license="LGPL-3.0-or-later"
-depends="python3 py3-requests py3-six"
-makedepends="py3-setuptools"
+depends="python3 py3-requests py3-six py3-setuptools"
checkdepends="py3-pytest py3-mock"
source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"