aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-20 09:56:02 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-20 09:56:38 +0000
commite0693032ca6fc455bd4984a5555acb0921ee105b (patch)
tree7fff4b6980372233d56a9678a6952a245fcf441f
parent9b06215ac9f662be2c7c5c18ecdec5076417b1c4 (diff)
testing/py-extras: new aport
-rw-r--r--testing/py-extras/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/py-extras/APKBUILD b/testing/py-extras/APKBUILD
new file mode 100644
index 00000000000..43d3b189a2b
--- /dev/null
+++ b/testing/py-extras/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-extras
+_pkgname=extras
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Useful extra bits for Python - things that shold be in the standard library"
+url="https://pypi.python.org/pypi/extras/"
+arch="noarch"
+license="MIT"
+depends="python"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}" ## remove if there are no common Python dependencies
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}" ## remove if there are no common Python dependencies
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python" ## remove if arch isn't noarch
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="510c796628f28db90bb96c7c9ba5fc9b2b950d2968e219efe67f3899bbe7ef68fe5de1494f8fd640f13a1ccd329e7dac9cd38aa965ab1e07c4cd287c04da50fb extras-1.0.0.tar.gz"