aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-19 12:56:00 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-12-19 12:56:00 -0300
commite27a8496798d9c9835763ef4ff2c05468491ff8f (patch)
treec4925155983af305315b8e57e97c80e6c4481805
parentd182850aadedc8a0cac89b2c274beb005606bcfc (diff)
community/libevdevplus: remove
-rw-r--r--community/libevdevplus/APKBUILD38
-rw-r--r--community/libevdevplus/time64.patch35
2 files changed, 0 insertions, 73 deletions
diff --git a/community/libevdevplus/APKBUILD b/community/libevdevplus/APKBUILD
deleted file mode 100644
index a5598af7b88..00000000000
--- a/community/libevdevplus/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
-pkgname=libevdevplus
-pkgver=0.1.1
-pkgrel=0
-pkgdesc="Wrapepr around evdev"
-options="!check" # Requires an input device
-url="https://github.com/YukiWorkshop/libevdevPlus"
-arch="all"
-license="MIT"
-depends_dev="linux-headers"
-makedepends="cmake $depends_dev"
-subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/YukiWorkshop/libevdevPlus/archive/v$pkgver.tar.gz
- time64.patch
- "
-builddir="$srcdir/libevdevPlus-$pkgver"
-
-build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=None \
- $CMAKE_CROSSOPTS .
- make -C build
-}
-
-package() {
- make -C build DESTDIR="$pkgdir" install
- rm -f "$pkgdir"/usr/lib/*.a
-}
-
-sha512sums="03e046bdd5ea985fb638e4cfa3c32bd4a50812203d563f5989bbaa817a9fe79472a314fe9307c9b9832f666ecfd4823b91c5dc6413ffae4432105e8d198d42d9 libevdevplus-0.1.1.tar.gz
-74a9438bb5945bc217004d7493202103c8daca0406a386fe5bb28f118872d6deac61d2b463aa5256f4befb8e4ff15d9185917977dcf3ba89f7cf460a2ced5b21 time64.patch"
diff --git a/community/libevdevplus/time64.patch b/community/libevdevplus/time64.patch
deleted file mode 100644
index e014c261226..00000000000
--- a/community/libevdevplus/time64.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/InputEvent.hpp b/InputEvent.hpp
-index 04ead03..16647b2 100644
---- a/InputEvent.hpp
-+++ b/InputEvent.hpp
-@@ -15,12 +15,16 @@
-
- #include "CommonIncludes.hpp"
-
-+#ifndef input_event_sec
-+#define input_event_sec time.tv_sec
-+#define input_event_usec time.tv_usec
-+#endif
-+
- namespace evdevPlus {
- class InputEvent {
- public:
- input_event event{};
-
-- timeval &Time = event.time;
- uint16_t &Type = event.type;
- uint16_t &Code = event.code;
- int32_t &Value = event.value;
-@@ -36,8 +40,10 @@ namespace evdevPlus {
- Code = code;
- Value = value;
-
-- if (time)
-- memcpy(&event.time, time, sizeof(timeval));
-+ if (time) {
-+ event.input_event_sec = time->tv_sec;
-+ event.input_event_usec = time->tv_usec;
-+ }
- }
-
- friend void swap(InputEvent &first, InputEvent &second) {