aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-29 20:03:49 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-05 17:52:59 +0000
commite4cce2ecb99c729717010da6d5c6b2df2028ef4e (patch)
tree16130ed441776fe17c5bb700709382088c7d0bbd
parent8a8c0794dd4a25d5f14875ea893a6dcda24c9f12 (diff)
community/gnome-keyring: enable PAM integration
This is required for stuff like automatically unlocking the keyring on unlock. * modernize APKBUILD * Fix homepage * adopt maintainership * Fix tests
-rw-r--r--community/gnome-keyring/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/gnome-keyring/APKBUILD b/community/gnome-keyring/APKBUILD
index a3562296c55..c8f0013d305 100644
--- a/community/gnome-keyring/APKBUILD
+++ b/community/gnome-keyring/APKBUILD
@@ -1,22 +1,21 @@
-# Contributor:
-# Maintainer:
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-keyring
pkgver=3.28.2
-pkgrel=0
+pkgrel=1
pkgdesc="GNOME keyring"
-url="http://www.gnome.org"
+url="https://wiki.gnome.org//Projects/GnomeKeyring"
arch="all"
-license="GPL"
-options="!check"
-makedepends="gtk+3.0-dev gcr-dev libcap-ng-dev
- intltool gobject-introspection-dev gtk-doc libxslt"
+license="GPL-2.0-only LGPL-2.0-only"
+makedepends="gtk+3.0-dev gcr-dev libcap-ng-dev linux-pam-dev
+ intltool gobject-introspection-dev gtk-doc libxslt
+ openssh-client libgcrypt-dev"
+checkdepends="python dbus-x11 xvfb-run"
+options="!check" # Gets stuck on CI
subpackages="$pkgname-lang $pkgname-doc"
source="https://download.gnome.org/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz
fix-includes.patch"
-builddir="${srcdir}/${pkgname}-${pkgver}"
-
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,8 +24,11 @@ build() {
make
}
+check() {
+ xvfb-run make check
+}
+
package() {
- cd "$builddir"
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR="$pkgdir" install
}