aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Yam <alex@alexyam.com>2021-02-17 22:13:09 +1100
committerLeo <thinkabit.ukim@gmail.com>2021-02-17 11:25:41 +0000
commite6bfd7316a25f13da965e511dbca2203a21f8535 (patch)
treed2c60bfdf9935ed131394b5f7c3bbd6dbd9fcf49
parent54c13a1af6465bcc14ad781dad27fe6d3477f3f0 (diff)
testing/vbindiff: new aport
https://www.cjmweb.net/vbindiff/ ncurses hex editor with diff mode for binary file comparison, supports files up to 4GB
-rwxr-xr-xtesting/vbindiff/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/vbindiff/APKBUILD b/testing/vbindiff/APKBUILD
new file mode 100755
index 00000000000..838e40795d3
--- /dev/null
+++ b/testing/vbindiff/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Alex Yam <alex@alexyam.com>
+# Maintainer: Alex Yam <alex@alexyam.com>
+pkgname=vbindiff
+pkgver=3.0_beta5
+pkgrel=0
+pkgdesc="ncurses hex editor with diff mode for binary file comparison, supports files up to 4GB"
+url="https://www.cjmweb.net/vbindiff/"
+arch="all"
+license="GPL-2.0-or-later"
+depends="ncurses-dev"
+options="!check" # no test suite
+source="https://www.cjmweb.net/vbindiff/vbindiff-$pkgver.tar.gz"
+subpackages="$pkgname-doc"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="cc9bc3b950f7b452fbc231f5cf4976b428dbeb96bfe13d518829f8a58898174a4c3b4b1ca0ed075c5b71c7ec27a8e7db4d09e36db74f727e40c524941dd8dbcc vbindiff-3.0_beta5.tar.gz"