aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-05-15 06:36:04 +0000
committerpsykose <alice@ayaya.dev>2023-05-15 08:36:37 +0200
commite6ec1a233a063a2ac53689d4a74596d4acf0313a (patch)
tree159df2723ff94f1416a348613b45790492e548cb
parentbc7b6a1932be264b162a4dc49de408a219535d2c (diff)
main/zeromq: fix gcc13 build
-rw-r--r--main/zeromq/APKBUILD5
-rw-r--r--main/zeromq/gcc13.patch60
2 files changed, 64 insertions, 1 deletions
diff --git a/main/zeromq/APKBUILD b/main/zeromq/APKBUILD
index d9a38dac789..b79c564b437 100644
--- a/main/zeromq/APKBUILD
+++ b/main/zeromq/APKBUILD
@@ -17,7 +17,9 @@ makedepends="
xmlto
"
subpackages="libzmq-static $pkgname-dev libzmq:libs"
-source="https://github.com/zeromq/libzmq/releases/download/v$pkgver/zeromq-$pkgver.tar.gz"
+source="https://github.com/zeromq/libzmq/releases/download/v$pkgver/zeromq-$pkgver.tar.gz
+ gcc13.patch
+ "
# secfixes:
# 4.3.3-r0:
@@ -59,4 +61,5 @@ package() {
sha512sums="
e198ef9f82d392754caadd547537666d4fba0afd7d027749b3adae450516bcf284d241d4616cad3cb4ad9af8c10373d456de92dc6d115b037941659f141e7c0e zeromq-4.3.4.tar.gz
+d1ee736e872075ac6b3e3917071e8bbe5cea7f0a734509a07cd0986aed7130fb4c49c4da4ca830df5d0924bd4796db79b97bfe9c6a0c2f1c3918b8185c0224eb gcc13.patch
"
diff --git a/main/zeromq/gcc13.patch b/main/zeromq/gcc13.patch
new file mode 100644
index 00000000000..7796cebb698
--- /dev/null
+++ b/main/zeromq/gcc13.patch
@@ -0,0 +1,60 @@
+Patch-Source: https://github.com/zeromq/libzmq/commit/438d5d88392baffa6c2c5e0737d9de19d6686f0d
+--
+From 438d5d88392baffa6c2c5e0737d9de19d6686f0d Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Tue, 20 Dec 2022 21:45:16 +0000
+Subject: [PATCH] src/secure_allocator.hpp: define missing 'rebind' type
+
+`gcc-13` added an assert to standard headers to make sure custom
+allocators have intended implementation of rebind type instead
+of inherited rebind. gcc change:
+ https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=64c986b49558a7
+
+Without the fix build fails on this week's `gcc-13` as:
+
+ [ 92%] Building CXX object tests/CMakeFiles/test_security_curve.dir/test_security_curve.cpp.o
+ In file included from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/ext/alloc_traits.h:34,
+ from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_uninitialized.h:64,
+ from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/memory:69,
+ from tests/../src/secure_allocator.hpp:42,
+ from tests/../src/curve_client_tools.hpp:49,
+ from tests/test_security_curve.cpp:53:
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h: In instantiation of 'struct std::__allocator_traits_base::__rebind<zmq::secure_allocator_t<unsigned char>, unsigned char, void>':
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:94:11: required by substitution of 'template<class _Alloc, class _Up> using std::__alloc_rebind = typename std::__allocator_traits_base::__rebind<_Alloc, _Up>::type [with _Alloc = zmq::secure_allocator_t<unsigned char>; _Up = unsigned char]'
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:228:8: required by substitution of 'template<class _Alloc> template<class _Tp> using std::allocator_traits< <template-parameter-1-1> >::rebind_alloc = std::__alloc_rebind<_Alloc, _Tp> [with _Tp = unsigned char; _Alloc = zmq::secure_allocator_t<unsigned char>]'
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/ext/alloc_traits.h:126:65: required from 'struct __gnu_cxx::__alloc_traits<zmq::secure_allocator_t<unsigned char>, unsigned char>::rebind<unsigned char>'
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_vector.h:88:21: required from 'struct std::_Vector_base<unsigned char, zmq::secure_allocator_t<unsigned char> >'
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_vector.h:423:11: required from 'class std::vector<unsigned char, zmq::secure_allocator_t<unsigned char> >'
+ tests/../src/curve_client_tools.hpp:64:76: required from here
+ /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:70:31: error: static assertion failed: allocator_traits<A>::rebind_alloc<A::value_type> must be A
+ 70 | _Tp>::value,
+ | ^~~~~
+
+The change adds trivial `rebind` definition with expected return type
+and satisfies conversion requirements.
+---
+ src/secure_allocator.hpp | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/src/secure_allocator.hpp b/src/secure_allocator.hpp
+index e0871dcc99..5e97368911 100644
+--- a/src/secure_allocator.hpp
++++ b/src/secure_allocator.hpp
+@@ -99,6 +99,17 @@ bool operator!= (const secure_allocator_t<T> &, const secure_allocator_t<U> &)
+ #else
+ template <typename T> struct secure_allocator_t : std::allocator<T>
+ {
++ secure_allocator_t () ZMQ_DEFAULT;
++
++ template <class U>
++ secure_allocator_t (const secure_allocator_t<U> &) ZMQ_NOEXCEPT
++ {
++ }
++
++ template <class U> struct rebind
++ {
++ typedef secure_allocator_t<U> other;
++ };
+ };
+ #endif
+ }