aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-04-08 11:57:37 +0200
committerBart Ribbers <bribbers@disroot.org>2021-04-09 09:31:32 +0200
commite804aedc351d29c0bc12ece9d08feec8fe9ad16b (patch)
treec3f85f432a48eca9b121df26650ca68abc0a7bf6
parent67514f0901a20930cb3669135b63174d3e00ef95 (diff)
community/qt5-qtsvg: apply latest KDE patches
-rw-r--r--community/qt5-qtsvg/0001-Add-changes-file-for-Qt-5.12.10.patch69
-rw-r--r--community/qt5-qtsvg/0003-Improve-handling-of-malformed-numeric-values-in-svg-.patch41
-rw-r--r--community/qt5-qtsvg/APKBUILD24
3 files changed, 14 insertions, 120 deletions
diff --git a/community/qt5-qtsvg/0001-Add-changes-file-for-Qt-5.12.10.patch b/community/qt5-qtsvg/0001-Add-changes-file-for-Qt-5.12.10.patch
deleted file mode 100644
index f6b37d6ab8c..00000000000
--- a/community/qt5-qtsvg/0001-Add-changes-file-for-Qt-5.12.10.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From e82cf6e005d43be9c49fb3f931433e5d508534f0 Mon Sep 17 00:00:00 2001
-From: Antti Kokko <antti.kokko@qt.io>
-Date: Thu, 15 Oct 2020 09:53:19 +0300
-Subject: [PATCH 1/5] Add changes file for Qt 5.12.10
-
-Change-Id: I08a4c977fe1652853e79ea6ce53b071db72b6986
-Reviewed-by: Robert Loehning <robert.loehning@qt.io>
-(cherry picked from commit 261ed79b966065f4ce398f1a701be6298dd49be9)
-Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
----
- dist/changes-5.12.10 | 46 ++++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 46 insertions(+)
- create mode 100644 dist/changes-5.12.10
-
-diff --git a/dist/changes-5.12.10 b/dist/changes-5.12.10
-new file mode 100644
-index 0000000..b8f8f69
---- /dev/null
-+++ b/dist/changes-5.12.10
-@@ -0,0 +1,46 @@
-+Qt 5.12.10 is a bug-fix release. It maintains both forward and backward
-+compatibility (source and binary) with Qt 5.12.9.
-+
-+For more details, refer to the online documentation included in this
-+distribution. The documentation is also available online:
-+
-+ https://doc.qt.io/qt-5.12/index.html
-+
-+The Qt version 5.12 series is binary compatible with the 5.11.x series.
-+Applications compiled for 5.11 will continue to run with 5.12.
-+
-+Some of the changes listed in this file include issue tracking numbers
-+corresponding to tasks in the Qt Bug Tracker:
-+
-+ https://bugreports.qt.io/
-+
-+Each of these identifiers can be entered in the bug tracker to obtain more
-+information about a particular change.
-+
-+****************************************************************************
-+* Library *
-+****************************************************************************
-+
-+ - This release fixes a number of cases where input fuzzing has
-+ revealed that corrupt or pathological input could result in crashes
-+ or undefined behavior:
-+ oss-fuzz-23588
-+ oss-fuzz-23606
-+ oss-fuzz-23633
-+ oss-fuzz-23643
-+ oss-fuzz-23644
-+ oss-fuzz-23731
-+ oss-fuzz-24000
-+ oss-fuzz-24028
-+ oss-fuzz-24131
-+ oss-fuzz-24146
-+ oss-fuzz-24308
-+ oss-fuzz-24611
-+ oss-fuzz-24738
-+
-+Third-Party Code
-+----------------
-+
-+ - XSVG license was re-classified to HPND-sell-variant, "Historical Permission
-+ Notice and Disclaimer - sell variant"
-+
---
-2.31.1
-
diff --git a/community/qt5-qtsvg/0003-Improve-handling-of-malformed-numeric-values-in-svg-.patch b/community/qt5-qtsvg/0003-Improve-handling-of-malformed-numeric-values-in-svg-.patch
deleted file mode 100644
index d2f8f54f21c..00000000000
--- a/community/qt5-qtsvg/0003-Improve-handling-of-malformed-numeric-values-in-svg-.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From aceea78cc05ac8ff947cee9de8149b48771781a8 Mon Sep 17 00:00:00 2001
-From: Eirik Aavitsland <eirik.aavitsland@qt.io>
-Date: Tue, 1 Dec 2020 14:39:59 +0100
-Subject: [PATCH 4/5] Improve handling of malformed numeric values in svg files
-
-Catch cases where the input is not containable in a qreal, and avoid
-passing on inf values.
-
-Change-Id: I1ab8932d94473916815385240c29e03afb0e0c9e
-Reviewed-by: Robert Loehning <robert.loehning@qt.io>
-Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
-(cherry picked from commit 428d56da9d5ed9bda51f7cc3c144996fb3a6a285)
-Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
----
- src/svg/qsvghandler.cpp | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/svg/qsvghandler.cpp b/src/svg/qsvghandler.cpp
-index c937254..b3d9aaf 100644
---- a/src/svg/qsvghandler.cpp
-+++ b/src/svg/qsvghandler.cpp
-@@ -65,6 +65,7 @@
- #include "private/qmath_p.h"
-
- #include "float.h"
-+#include <cmath>
-
- QT_BEGIN_NAMESPACE
-
-@@ -672,6 +673,8 @@ static qreal toDouble(const QChar *&str)
- val = -val;
- } else {
- val = QByteArray::fromRawData(temp, pos).toDouble();
-+ if (qFpClassify(val) != FP_NORMAL)
-+ val = 0;
- }
- return val;
-
---
-2.31.1
-
diff --git a/community/qt5-qtsvg/APKBUILD b/community/qt5-qtsvg/APKBUILD
index f221e6c6f79..72c1ade56e7 100644
--- a/community/qt5-qtsvg/APKBUILD
+++ b/community/qt5-qtsvg/APKBUILD
@@ -1,25 +1,31 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt5-qtsvg
-pkgver=5.15.2
-pkgrel=3
+pkgver=5.15.3_git20200406
+pkgrel=0
+_commit="95990cbeebc0ab9959e2a925a93ad4897416bbb7"
pkgdesc="Qt5 - Support for rendering and displaying SVG"
url="https://www.qt.io/developers/"
arch="all"
license="(LGPL-2.0-or-later OR GPL-3.0-only OR GPL-2.0-or-later) AND Qt-GPL-exception-1.0"
makedepends="qt5-qtbase-dev zlib-dev"
subpackages="$pkgname-dev"
-builddir="$srcdir/qtsvg-everywhere-src-$pkgver"
+builddir="$srcdir/qtsvg-$_commit"
case $pkgver in
*_beta*|*_rc*) _rel=development_releases;;
*) _rel=official_releases;;
esac
-source="https://download.qt.io/$_rel/qt/${pkgver%.*}/$pkgver/submodules/qtsvg-everywhere-src-$pkgver.tar.xz
- 0001-Add-changes-file-for-Qt-5.12.10.patch
- 0003-Improve-handling-of-malformed-numeric-values-in-svg-.patch
- "
+source="https://invent.kde.org/qt/qt/qtsvg/-/archive/$_commit/qtsvg-$_commit.tar.gz"
+
+prepare() {
+ default_prepare
+
+ # We need to make the build system think we're running in a git repository
+ # so it correctly symlinks during the build
+ mkdir .git
+}
build() {
qmake-qt5
@@ -41,6 +47,4 @@ package() {
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
-sha512sums="101e9c8fc05b1bb9c4e869564bff8e5723dd35f0ef557185e56e9dc12fdce74c531522c9642cdff639900eccf7ed0e04bfa48142741259697dded990fb481730 qtsvg-everywhere-src-5.15.2.tar.xz
-ed2e77abed8e93b10fcc23d6c5b9f08c53fa0cfe2ed36ddb30f8140846238fedcd7e1f9a0c76cc4b8ee2b35f34b34d39d078616c5e8c8b60006166d70d17908c 0001-Add-changes-file-for-Qt-5.12.10.patch
-11f4651321f9094599d0dfbe322e403f0139b7322a4c543e3ce5e8fa2b1d5880f2f08ff4898743f697f2ec0e64a3b2102a6e815cc9cdd59f636e24374a5609f9 0003-Improve-handling-of-malformed-numeric-values-in-svg-.patch"
+sha512sums="e9ca3937233e91be9e40cfb6d792b87ffdf98f7ee24e57b0182e68967a9a2c61a492233e36294b87f8e7355659236865b9d730effa83b106a5768b13c61ad470 qtsvg-95990cbeebc0ab9959e2a925a93ad4897416bbb7.tar.gz"