aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-03-16 20:35:31 +0100
committerBart Ribbers <bribbers@disroot.org>2021-03-16 21:22:22 +0100
commite986632ad24d9162529c27607f2ed7d5ecf8a88a (patch)
treea7a525496543881e1397dda202ee74b73d38857c
parent0f3295fb0660f5caf59b8b2385f7c9305f1d57f0 (diff)
community/sink: upgrade to 0.9.0 and re-enable on armv7
-rw-r--r--community/sink/APKBUILD35
-rw-r--r--community/sink/fix-build-failures.patch44
2 files changed, 24 insertions, 55 deletions
diff --git a/community/sink/APKBUILD b/community/sink/APKBUILD
index 634433fca9b..1bfb4416458 100644
--- a/community/sink/APKBUILD
+++ b/community/sink/APKBUILD
@@ -1,19 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=sink
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=0
pkgdesc="Offline caching, synchronization and indexing system for PIM data"
-arch="aarch64 ppc64le x86 x86_64" # limited by flatbuffers
+arch="all !armhf !mips64" # limited by flatbuffers
url="https://community.kde.org/KDE_PIM"
license="LicenseRef-KDE-Accepted-GPL"
-depends_dev="qt5-qtbase-dev kmime-dev kcontacts-dev kcalendarcore-dev xapian-core-dev lmdb-dev kasync-dev kimap2-dev kdav2-dev curl-dev flatbuffers-dev libexecinfo-dev"
-makedepends="$depends_dev extra-cmake-modules"
-source="https://download.kde.org/unstable/sink/$pkgver/src/sink-$pkgver.tar.xz
- fix-build-failures.patch
+depends_dev="
+ curl-dev
+ flatbuffers-dev
+ gpgme-dev
+ kasync-dev
+ kcalendarcore-dev
+ kcontacts-dev
+ kdav2-dev
+ kimap2-dev
+ kmime-dev
+ libexecinfo-dev
+ lmdb-dev
+ qt5-qtbase-dev
+ xapian-core-dev
"
+makedepends="$depends_dev extra-cmake-modules"
+checkdepends="xvfb-run"
+source="https://invent.kde.org/pim/sink/-/archive/v$pkgver/sink-v$pkgver.tar.gz"
subpackages="$pkgname-dev"
-options="!check" # Tests compilation is broken
+options="!check" # Failing tests
+builddir="$srcdir/$pkgname-v$pkgver"
build() {
cmake -B build \
@@ -25,11 +39,10 @@ build() {
check() {
cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="008ca8355ffbed2bf89a906510aac4c505c8e44de49f445db283aa565e233e7652f2e46c5bcf37e680dec940a8c0f1525e6a8f708e1b4742db62522255c8bad6 sink-0.8.0.tar.xz
-b4a68367f1866e67aa8787b1d54ba27464a92b4a0c096944ad691fbd883fe70e5829cc886e04ec287e8be71808bd70bd3c7ffafb9de8e46e4c3193af2cd918dd fix-build-failures.patch"
+sha512sums="8f64872827978196178115ea46db655479cf7b88086ff6ec6e60000c5edd57f9cf0d51a8d7cb11660b987a6b3a0f9a8a985e264c6ba988965cfce49a631e428b sink-v0.9.0.tar.gz"
diff --git a/community/sink/fix-build-failures.patch b/community/sink/fix-build-failures.patch
deleted file mode 100644
index ee695bd6143..00000000000
--- a/community/sink/fix-build-failures.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Required to make Sink build.
-The function "printStacktrace" makes use of backtrace which is not available on Alpine.
-https://invent.kde.org/pim/sink/-/issues/2
-
-Building of the examples and tests are broken
-https://invent.kde.org/pim/sink/-/issues/1
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 178b0293..9d320f40 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -150,11 +150,15 @@ add_subdirectory(common)
- # the synchronizer
- add_subdirectory(synchronizer)
-
--# example implementations
--add_subdirectory(examples)
-+if(BUILD_EXAMPLES)
-+ # example implementations
-+ add_subdirectory(examples)
-+endif()
-
--# some tests
--add_subdirectory(tests)
-+if(BUILD_TESTS)
-+ # some tests
-+ add_subdirectory(tests)
-+endif()
-
- # cli
- add_subdirectory(sinksh)
-diff --git a/synchronizer/backtrace.cpp b/synchronizer/backtrace.cpp
-index bd993ccb..597694bf 100644
---- a/synchronizer/backtrace.cpp
-+++ b/synchronizer/backtrace.cpp
-@@ -250,7 +250,9 @@ static void crashHandler(int signal)
- std::cerr << "Unexpected signal " << signal << " received\n";
- }
-
-+#if defined(__GLIBC__)
- printStacktrace();
-+#endif // __GLIBC__
-
- //Get the word out that we're going down
- if (sListener) {