aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-03-17 20:50:16 +0000
committerpsykose <alice@ayaya.dev>2023-03-17 21:50:16 +0100
commitea5154ebc7b09179497cf2d6488dd9e3f16b1ad1 (patch)
tree509814999323aa3a733bdd9dc4385815cee24d55
parente0a37e053252730c7f580f33f5847e673b9a38b8 (diff)
community/synapse: relax canonicaljson
closes #14726
-rw-r--r--community/synapse/APKBUILD4
-rw-r--r--community/synapse/relax-version-dep-frozendict.patch13
2 files changed, 10 insertions, 7 deletions
diff --git a/community/synapse/APKBUILD b/community/synapse/APKBUILD
index e68fa9fae4a..a23be719257 100644
--- a/community/synapse/APKBUILD
+++ b/community/synapse/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: 6543 <6543@obermui.de>
pkgname=synapse
pkgver=1.79.0
-pkgrel=0
+pkgrel=1
pkgdesc="Matrix reference homeserver"
url="https://github.com/matrix-org/synapse"
arch="all"
@@ -129,5 +129,5 @@ sha512sums="
0ba9e0513ee4eccea7de270c9d3e4775b044a6815bb22b5b12cf4d36b367fb30cb3e7be0b7c0e1c8634e439acc2b5b37e6ee40095f48e089502cb648b91dabdf synapse-1.79.0.tar.gz
7ac08b676b246647ebfa50f46525ed81d4fa53e83ab11d984f1cedc79ffbbcf12234424215f44f7038b82b7523c1e2fcac306d8bdc9d64648c5d994017b51e55 synapse.initd
7c022f0e00c8ac363d6d2e003b6389fb06a3934f68390ebac156cb46bc1366585e6b6cda07b15176bc62a00f5bf21bfda153ff5418b07331257a7075102a6f83 synapse.confd
-8ac26e7d94121cee13f0492ef65ea1abf612f6b310cd6c802a4772f9a5ea5d3e8286b2e3446510f324361b8459b53b77b5801b0e3c86ba69d2235b071a2d8f3d relax-version-dep-frozendict.patch
+325363def95df923914769fdfabadba3fc7bba115dc42ec5672adcacf626edfc573b786a898975ca14c3289af7ba2af0c58278777b0f3d449da5f985563f6070 relax-version-dep-frozendict.patch
"
diff --git a/community/synapse/relax-version-dep-frozendict.patch b/community/synapse/relax-version-dep-frozendict.patch
index 2a600b0fc2a..756dcfe839d 100644
--- a/community/synapse/relax-version-dep-frozendict.patch
+++ b/community/synapse/relax-version-dep-frozendict.patch
@@ -8,10 +8,10 @@ Subject: [PATCH] relax-version-dep-frozendict
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/pyproject.toml b/pyproject.toml
-index 482644e04..d7433f244 100644
+index 4dc228e..f0ef910 100644
--- a/pyproject.toml
+++ b/pyproject.toml
-@@ -156,7 +156,7 @@ jsonschema = ">=3.0.0"
+@@ -156,12 +156,12 @@ jsonschema = ">=3.0.0"
# frozendict 2.1.2 is broken on Debian 10: https://github.com/Marco-Sulla/python-frozendict/issues/41
# We cannot test our wheels against the 2.3.5 release in CI. Putting in an upper bound for this
# because frozendict has been more trouble than it's worth; we would like to move to immutabledict.
@@ -20,6 +20,9 @@ index 482644e04..d7433f244 100644
# We require 2.1.0 or higher for type hints. Previous guard was >= 1.1.0
unpaddedbase64 = ">=2.1.0"
# We require 1.5.0 to work around an issue when running against the C implementation of
---
-2.34.1
-
+ # frozendict: https://github.com/matrix-org/python-canonicaljson/issues/36
+-canonicaljson = "^1.5.0"
++canonicaljson = ">=0"
+ # we use the type definitions added in signedjson 1.1.
+ signedjson = "^1.1.0"
+ # validating SSL certs for IP addresses requires service_identity 18.1.