aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-07-21 19:16:37 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-07-22 19:03:07 +0000
commitea8095d2f0259e83209946a44dbac891800db189 (patch)
treed2e37745b7fd84596080a574bbbfed73f3623eab
parent84ac072b675a2668377805b731e59e097525352c (diff)
main/nettle: upgrade to 3.5.1
-rw-r--r--main/nettle/APKBUILD26
-rw-r--r--main/nettle/nettle-2.4-makefile.patch11
2 files changed, 7 insertions, 30 deletions
diff --git a/main/nettle/APKBUILD b/main/nettle/APKBUILD
index e02c9d8d243..9ccb67c4976 100644
--- a/main/nettle/APKBUILD
+++ b/main/nettle/APKBUILD
@@ -2,29 +2,19 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=nettle
-pkgver=3.4.1
-pkgrel=1
+pkgver=3.5.1
+pkgrel=0
pkgdesc="A low-level cryptographic library"
-url="http://www.lysator.liu.se/~nisse/nettle/"
+url="https://www.lysator.liu.se/~nisse/nettle/"
arch="all"
license="LGPL-2.0-or-later"
-depends=""
depends_dev="gmp-dev"
makedepends="$depends_dev m4"
subpackages="$pkgname-dev $pkgname-utils"
-source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
- nettle-2.4-makefile.patch"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
- local _arch_opts=
-
- case "$CARCH" in
- armhf|armv7)
- _arch_opts="--disable-arm-neon"
- esac
-
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -34,22 +24,21 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
+ --enable-fat \
--enable-shared \
--disable-openssl \
- $_arch_opts
+ --disable-static
make
# strip comments in fields from .pc as it confuses pkgconf
sed -i -e 's/ \#.*//' *.pc
}
check() {
- cd "$builddir"
make -C examples # required for rsa-encrypt
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -59,5 +48,4 @@ utils() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="26aefbbe9927e90e28f271e56d2ba876611831222d0e1e1a58bdb75bbd50934fcd84418a4fe47b845f557e60a9786a72a4de2676c930447b104f2256aca7a54f nettle-3.4.1.tar.gz
-c7d9741a7a37d225f3f0db16d355e13b04cc0f1ac56882a6ff31ef15c1a1a0aee7a70cf1ec8bbf2c46b9b0dcec153da7a7aa6b8909a72d76dd4d669cbbaceaa4 nettle-2.4-makefile.patch"
+sha512sums="f738121b9091cbe79435fb5d46b45cf6f10912320c233829356908127bab1cac6946ca56e022a832380c44f2c10f21d2feef64cb0f4f41e3da4a681dc0131784 nettle-3.5.1.tar.gz"
diff --git a/main/nettle/nettle-2.4-makefile.patch b/main/nettle/nettle-2.4-makefile.patch
deleted file mode 100644
index c216365a111..00000000000
--- a/main/nettle/nettle-2.4-makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- nettle-2.4/Makefile.in.orig
-+++ nettle-2.4/Makefile.in
-@@ -14,7 +14,7 @@
- INSTALL_STRIP_PROGRAM = $(INSTALL_PROGRAM) -s
- MKDIR_P = @MKDIR_P@
-
--SUBDIRS = tools testsuite examples
-+SUBDIRS = tools testsuite
-
- include config.make
-