aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2022-01-16 19:04:33 +0100
committerJakub Jirutka <jakub@jirutka.cz>2022-01-16 20:08:39 +0100
commitebdb376712e2197a3f1767fcf41ca86865ab0253 (patch)
treea3dfc2eb8b8420618eed0a77821c8c5c139a1cdf
parent66736fbf1ac9e9a56e56718529784db0fffd51c2 (diff)
community/gtk-layer-shell: disable annoying warning for newer GTK versions
-rw-r--r--community/gtk-layer-shell/APKBUILD11
-rw-r--r--community/gtk-layer-shell/disable-warn_gtk_version_may_be_unsupported.patch17
2 files changed, 25 insertions, 3 deletions
diff --git a/community/gtk-layer-shell/APKBUILD b/community/gtk-layer-shell/APKBUILD
index df630e6d2a2..30337bc244e 100644
--- a/community/gtk-layer-shell/APKBUILD
+++ b/community/gtk-layer-shell/APKBUILD
@@ -2,14 +2,16 @@
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=gtk-layer-shell
pkgver=0.6.0
-pkgrel=0
+pkgrel=1
pkgdesc="Create panels and other desktop components in Wayland using the Layer Shell protocol"
url="https://github.com/wmww/gtk-layer-shell"
arch="all"
license="MIT"
makedepends="meson wayland-dev gtk+3.0-dev gobject-introspection-dev"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/wmww/gtk-layer-shell/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/wmww/gtk-layer-shell/archive/v$pkgver.tar.gz
+ disable-warn_gtk_version_may_be_unsupported.patch
+ "
build() {
abuild-meson \
@@ -28,4 +30,7 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="ca5367b5f1637a07c28c772e79e5ac84219ff069091077f83c5edbc88be084538a925b3c76e6cc9dcd8d2826ae340b79605875e87209ee4f4d5e27dc4e93a523 gtk-layer-shell-0.6.0.tar.gz"
+sha512sums="
+ca5367b5f1637a07c28c772e79e5ac84219ff069091077f83c5edbc88be084538a925b3c76e6cc9dcd8d2826ae340b79605875e87209ee4f4d5e27dc4e93a523 gtk-layer-shell-0.6.0.tar.gz
+e5219f2ea9ee91933d99b3e825b5223c5cb296672974afcdf24149bf801088fa444aa68828eadf88b1ba16f79641144d344032429e7f899bfbca2433dce083f3 disable-warn_gtk_version_may_be_unsupported.patch
+"
diff --git a/community/gtk-layer-shell/disable-warn_gtk_version_may_be_unsupported.patch b/community/gtk-layer-shell/disable-warn_gtk_version_may_be_unsupported.patch
new file mode 100644
index 00000000000..3bc616f501b
--- /dev/null
+++ b/community/gtk-layer-shell/disable-warn_gtk_version_may_be_unsupported.patch
@@ -0,0 +1,17 @@
+Disable annoying warning for newer GTK versions
+
+https://github.com/wmww/gtk-layer-shell/blob/master/compatibility.md
+> GTK Layer Shell has a hard time explicitly supporting each version of
+> GTK, but *new unsupported versions almost always work in practice*.
+
+--- a/gtk-priv/h/common.h
++++ b/gtk-priv/h/common.h
+@@ -24,7 +24,7 @@
+ }
+
+ void gtk_priv_warn_gtk_version_may_be_unsupported() {
+- static gboolean shown = FALSE;
++ static gboolean shown = TRUE;
+ if (shown)
+ return;
+ g_warning(