aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-22 17:06:12 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-22 20:52:42 -0300
commitec2be6179364e55867dbe572b0ee9497d39992aa (patch)
tree8681652781aca0e4c1b916c77e9a5a72156851dc
parent2bf1c7eca436eaa039a5874d1870cd361830845a (diff)
community/zathura: fix license, use python3 to build manpages
-rw-r--r--community/zathura/APKBUILD17
-rw-r--r--community/zathura/doc-py3.patch11
2 files changed, 19 insertions, 9 deletions
diff --git a/community/zathura/APKBUILD b/community/zathura/APKBUILD
index a5085db2c1a..f35276d501f 100644
--- a/community/zathura/APKBUILD
+++ b/community/zathura/APKBUILD
@@ -4,35 +4,34 @@
# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
pkgname=zathura
pkgver=0.4.3
-pkgrel=0
+pkgrel=1
pkgdesc="zathura - highly customizable and functional document viewer"
url="https://git.pwmt.org/pwmt/zathura"
arch="all"
-license="zlib"
+license="Zlib"
depends="libmagic"
makedepends="girara-dev file-dev sqlite-dev intltool check-dev libseccomp-dev
- py-docutils ncurses meson ninja py-sphinx desktop-file-utils"
+ py3-docutils ncurses meson ninja py3-sphinx desktop-file-utils"
checkdepends="mesa-dri-swrast dbus xvfb"
subpackages="$pkgname-doc $pkgname-dev $pkgname-lang"
source="https://git.pwmt.org/pwmt/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz
- test.sh"
-builddir="$srcdir/$pkgname-$pkgver"
+ test.sh
+ doc-py3.patch
+ "
build() {
- cd "$builddir"
meson build --prefix=/usr
ninja -C build
}
check() {
- cd "$builddir"
"$srcdir/test.sh"
}
package() {
- cd "$builddir"
DESTDIR="$pkgdir" ninja -C build install
}
sha512sums="c991f2523cc13f00c7017b150dcf2e41a3f700ce229fcea229cc67e4b4c9aad69b716c0f3ed2d911667855ed134b07e2ee48d0e7745a1ccac0e45281c5aa8136 zathura-0.4.3.tar.gz
-2190d324753810c8dc5b109274dcf4f644e51edcda876c225ac76369dd569dda0b8db445b01dac1ac2b06178534d18e1074ca37d1a69622bdc58fd77350b4ddd test.sh"
+2190d324753810c8dc5b109274dcf4f644e51edcda876c225ac76369dd569dda0b8db445b01dac1ac2b06178534d18e1074ca37d1a69622bdc58fd77350b4ddd test.sh
+7956eb2d925e1cd415846dc8116399a34af7fcb14aa6573b3328893f57b845cda91dc2e709d0b4a23b3c808dda946b48d7eb8d2a68d0fb2eb965556ff0f90702 doc-py3.patch"
diff --git a/community/zathura/doc-py3.patch b/community/zathura/doc-py3.patch
new file mode 100644
index 00000000000..b9bc5a96f12
--- /dev/null
+++ b/community/zathura/doc-py3.patch
@@ -0,0 +1,11 @@
+diff --git a/doc/meson.build b/doc/meson.build
+index d178322..4e8ee7c 100644
+--- a/doc/meson.build
++++ b/doc/meson.build
+@@ -1,4 +1,4 @@
+-sphinx = find_program('sphinx-build', required: get_option('manpages'))
++sphinx = find_program('sphinx-build-3', required: get_option('manpages'))
+ if sphinx.found()
+ custom_target('man pages',
+ command: [
+