aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2022-05-13 13:54:28 +0200
committerJakub Jirutka <jakub@jirutka.cz>2022-06-09 13:39:38 +0000
commitec7d4a41dd328d09f734ed163f82e5583cde38c0 (patch)
tree5d1f481748143b07dde7447217c9b5cf1cdc9328
parentdfc15db49382238627ec94d6375c6d10f77e7fa4 (diff)
community/postgresql12: upgrade to 12.11
-rw-r--r--community/postgresql12/APKBUILD8
-rw-r--r--community/postgresql12/fix-test-temp-schema-cleanup.patch14
2 files changed, 20 insertions, 2 deletions
diff --git a/community/postgresql12/APKBUILD b/community/postgresql12/APKBUILD
index c6a1831c7be..9ab3ba6df0a 100644
--- a/community/postgresql12/APKBUILD
+++ b/community/postgresql12/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: G.J.R. Timmer <gjr.timmer@gmail.com>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
_pkgname=postgresql
-pkgver=12.10
+pkgver=12.11
pkgrel=0
_majorver=${pkgver%%.*}
# Should this aport provide libpq* and libecpg*? true/false
@@ -65,6 +65,7 @@ subpackages="
$pkgname-openrc
"
source="https://ftp.postgresql.org/pub/source/v$pkgver/postgresql-$pkgver.tar.bz2
+ fix-test-temp-schema-cleanup.patch
initdb.patch
perl-rpath.patch
per-version-dirs.patch
@@ -83,6 +84,8 @@ source="https://ftp.postgresql.org/pub/source/v$pkgver/postgresql-$pkgver.tar.bz
builddir="$srcdir/$_pkgname-$pkgver"
# secfixes:
+# 12.11-r0:
+# - CVE-2022-1552
# 12.9-r0:
# - CVE-2021-23214
# - CVE-2021-23222
@@ -470,7 +473,8 @@ _setdiff() {
}
sha512sums="
-befedb14320aa033dc55bbb93bbbec4e67d9cfced63be0e4f631c7495a0fbc6fe280bd6d2fb941d7a2e6b2ac570b7f40d8db7f07a192a81bd9cd63c6c244a9c5 postgresql-12.10.tar.bz2
+705e9e1ccf8202062cce61069b5ddb7db5f804dd0736c620640ce5622b9e42fdcbc1417771e77d51aa54beb4562a09b4307f2ff7dec135bd0e31f4941ca36ac8 postgresql-12.11.tar.bz2
+1826ad7dfea705b9f62bb913e45865b9d9aefec9b6115aa9f4a648caa8ce85767ebf342ca1acbc49ca645599360d6218a2b6cd022930d240f2c5702b9e87281b fix-test-temp-schema-cleanup.patch
1f8e7dc58f5b0a12427cf2fd904ffa898a34f23f3332c8382b94e0d991c007289e7913a69e04498f3d93fc5701855796c207b4b1cc4a0b366f586050124d7fcc initdb.patch
5f9d8bb4957194069d01af8ab3abc6d4d83a7e7f8bd7ebe1caae5361d621a3e58f91b14b952958138a794e0a80bc154fbb7e3e78d211e2a95b9b7901335de854 perl-rpath.patch
92d28f91b57a01afc81a00d386e87b9e2aa812f341a1578f262af372ee905530205592eda595111827582acceacd1bf244d1df130330003f05e74e4ddb5a7c4f per-version-dirs.patch
diff --git a/community/postgresql12/fix-test-temp-schema-cleanup.patch b/community/postgresql12/fix-test-temp-schema-cleanup.patch
new file mode 100644
index 00000000000..45ced2c05fc
--- /dev/null
+++ b/community/postgresql12/fix-test-temp-schema-cleanup.patch
@@ -0,0 +1,14 @@
+A nasty workaround for the faulty test.
+
+Related to https://www.postgresql.org/message-id/20220304.113347.2105652521035137491.horikyota.ntt@gmail.com
+but pg_terminate_backend() accepts the second argument since PostgreSQL 14.
+--- a/src/test/isolation/expected/temp-schema-cleanup.out
++++ b/src/test/isolation/expected/temp-schema-cleanup.out
+@@ -86,6 +86,7 @@
+ SELECT pg_terminate_backend(pg_backend_pid());
+
+ FATAL: terminating connection due to administrator command
++FATAL: terminating connection due to administrator command
+ server closed the connection unexpectedly
+ This probably means the server terminated abnormally
+ before or while processing the request.