aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-10-29 02:34:09 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-10-29 02:56:31 +0000
commiteee27533b162044b4ed7cb220bd13869eadfb775 (patch)
treeddc2e7e403baf3d04843441da93a0dac8404fba4
parent45580f93ae225cd300af7e18229b05d5f3fd57d8 (diff)
community/ssh-audit: upgrade to 2.3.1
-rw-r--r--community/ssh-audit/APKBUILD19
-rw-r--r--community/ssh-audit/policies-dir.patch18
2 files changed, 10 insertions, 27 deletions
diff --git a/community/ssh-audit/APKBUILD b/community/ssh-audit/APKBUILD
index afd31c86cf4..bced1dbeab6 100644
--- a/community/ssh-audit/APKBUILD
+++ b/community/ssh-audit/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=ssh-audit
-pkgver=2.3.0
+pkgver=2.3.1
pkgrel=0
pkgdesc="SSH server and client configuration auditing"
url="https://github.com/jtesta/ssh-audit"
@@ -10,18 +10,19 @@ arch="noarch"
depends="python3"
checkdepends="py3-pytest"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jtesta/ssh-audit/archive/v$pkgver.tar.gz
- policies-dir.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jtesta/ssh-audit/archive/v$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
check() {
- pytest
+ PYTHONPATH="$PWD"/build/lib pytest
}
package() {
- install -Dm755 ssh-audit.py "$pkgdir"/usr/bin/$pkgname
- install -Dm644 ssh-audit.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
- install -Dm644 -t "$pkgdir"/usr/share/ssh-audit/policies policies/*.txt
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ install -Dm644 -t "$pkgdir"/usr/share/man/man1 ssh-audit.1
}
-sha512sums="c2424191d09b9528ae07819b54585ef290c524274f4ad58be1749b4a7ba13fe6e65c126796e675d7c7989b3f901b35f840554bf8ca186b0f6ae9e1b4e275b409 ssh-audit-2.3.0.tar.gz
-ab61df27303ef353cfa5f1ca0475d7b6c0d1fc7842a65a72be6f254c1ee057bc5bc5688a013dc9ffe34616d87851ef4db9a1f76d0a52b36d8940c35e8a756312 policies-dir.patch"
+sha512sums="de7454d0348a947cb22e66021f9d4fd89e90f0b2a50e088d718e879e654b78f4300f4e2105a26a3390278315f6cb087577b7539525d02c5dcd48570ade6fe8ad ssh-audit-2.3.1.tar.gz"
diff --git a/community/ssh-audit/policies-dir.patch b/community/ssh-audit/policies-dir.patch
deleted file mode 100644
index a5b2426c58c..00000000000
--- a/community/ssh-audit/policies-dir.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Reason: Adjust policies directory for a system-wide installation
-Upstream: No
-
-diff --git a/ssh-audit.py b/ssh-audit.py
-index 3884996..52f7d81 100755
---- a/ssh-audit.py
-+++ b/ssh-audit.py
-@@ -3399,9 +3399,7 @@ def evaluate_policy(aconf: AuditConf, banner: Optional['SSH.Banner'], client_hos
-
- def list_policies() -> None:
-
-- # Get a list of all the files in the policies sub-directory, relative to the path of this script.
-- installed_dir = os.path.dirname(os.path.abspath(__file__))
-- policies_dir = os.path.join(installed_dir, 'policies')
-+ policies_dir = '/usr/share/ssh-audit/policies'
-
- # If the path is not a directory, print a useful error and exit.
- if not os.path.isdir(policies_dir):