aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-04 14:31:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-04 14:31:30 -0300
commiteeea38c8e334545967285a375bfd9a1fe3d0ab2b (patch)
tree8a6063a0fdcc84ee68fd99493ef99f79b2693fc7
parent370474cc94dc50d2eef6de7cf573b4174179a586 (diff)
testing/netcdf: fix build in s390x
Use a patch from debian: https://salsa.debian.org/debian-gis-team/netcdf/-/commit/18d5a1d35b1d3deab05d4150ca1939bc9fb215ba
-rw-r--r--testing/netcdf/APKBUILD7
-rw-r--r--testing/netcdf/byteswap.patch18
2 files changed, 23 insertions, 2 deletions
diff --git a/testing/netcdf/APKBUILD b/testing/netcdf/APKBUILD
index 0795b9c9ec9..f4e10cd411c 100644
--- a/testing/netcdf/APKBUILD
+++ b/testing/netcdf/APKBUILD
@@ -21,7 +21,9 @@ subpackages="
$pkgname-dev
$pkgname-utils:utils
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/Unidata/netcdf-c/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Unidata/netcdf-c/archive/v$pkgver.tar.gz
+ byteswap.patch
+ "
builddir="$srcdir/$pkgname-c-$pkgver"
build() {
@@ -57,4 +59,5 @@ check() {
# One test failure in nc_test as reported in https://github.com/Unidata/netcdf-c/issues/808
ctest -E nc_test
}
-sha512sums="15922818fdd71be285eb7dd2fc9be2594fe9af979de3ed316465636c7bbdaec65eb151ca57ef8b703e6a360cdba036b8f9bc193ddff01ff7ce4214c0a66efa79 netcdf-4.7.4.tar.gz"
+sha512sums="15922818fdd71be285eb7dd2fc9be2594fe9af979de3ed316465636c7bbdaec65eb151ca57ef8b703e6a360cdba036b8f9bc193ddff01ff7ce4214c0a66efa79 netcdf-4.7.4.tar.gz
+fa74a75eb064901878dc37b2049534bec7571885393f78692d7ac27ad9a1ec622574bf4bbfdb741d714c45b4a0b8a1ebbd532277603c154d50513eecad70d002 byteswap.patch"
diff --git a/testing/netcdf/byteswap.patch b/testing/netcdf/byteswap.patch
new file mode 100644
index 00000000000..eb4305be6a6
--- /dev/null
+++ b/testing/netcdf/byteswap.patch
@@ -0,0 +1,18 @@
+Description: Add forward declarations for byteswap8 & byteswap4.
+Author: Dennis Heimbigner
+Bug: https://github.com/Unidata/netcdf-c/issues/1687
+
+diff --git a/libdispatch/dfilter.c b/libdispatch/dfilter.c
+index 8938464..8efe591 100644
+--- a/libdispatch/dfilter.c
++++ b/libdispatch/dfilter.c
+@@ -20,6 +20,9 @@
+ #include "hdf5internal.h"
+ #endif
+
++static void byteswap8(unsigned char*);
++static void byteswap4(unsigned char*);
++
+ /*
+ Unified filter related code
+ */