aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2018-02-03 10:03:55 -0500
committerTimo Teräs <timo.teras@iki.fi>2018-02-05 19:35:12 +0000
commitef1621d7d3d32f8104b8b97276bf4832a4a6c35b (patch)
treee7d0b1d502138d2ca4b6719fea314c5b6d6f296d
parent5752087dbb4a03ccbc2c076a6403e5541733411d (diff)
main/json-c: support cross-compile
-rw-r--r--main/json-c/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/main/json-c/APKBUILD b/main/json-c/APKBUILD
index 467ad6790fc..08a3918dd85 100644
--- a/main/json-c/APKBUILD
+++ b/main/json-c/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=json-c
pkgver=0.12.1
-pkgrel=1
+pkgrel=2
pkgdesc="A JSON implementation in C"
url="https://github.com/json-c/json-c/wiki"
arch="all"
@@ -25,12 +25,15 @@ prepare() {
build() {
cd "$builddir"
./configure --prefix=/usr \
+ --build=$CBUILD \
+ --host=$CHOST \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--enable-shared \
- || return 1
+ ac_cv_func_malloc_0_nonnull=yes \
+ ac_cv_func_realloc_0_nonnull=yes
make -j1 || return 1
}