aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2016-08-11 15:07:29 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2016-08-15 17:54:31 +0000
commitef9e7838e923a9d679b3531637cbd62ae3c48775 (patch)
tree1cfc9390beb0550920fb13bd7e7e5671efbc7cd5
parent7ff87a1e3dbfa5e8df738c20250b25e7c9f26698 (diff)
community/mbedtls: upgrade to 2.3.0
-rw-r--r--community/mbedtls/APKBUILD33
1 files changed, 14 insertions, 19 deletions
diff --git a/community/mbedtls/APKBUILD b/community/mbedtls/APKBUILD
index cdffbf27559..bfcfc5ab853 100644
--- a/community/mbedtls/APKBUILD
+++ b/community/mbedtls/APKBUILD
@@ -1,32 +1,27 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mbedtls
-pkgver=2.2.1
+pkgver=2.3.0
pkgrel=0
pkgdesc="Light-weight cryptographic and SSL/TLS library"
url="https://tls.mbed.org/"
arch="all"
-license="GPLv2+ with exceptions"
+license="GPL2+ ASL 2.0"
depends=""
depends_dev=""
makedepends="$depends_dev cmake perl"
install=""
subpackages="$pkgname-static $pkgname-dev $pkgname-utils"
-source="https://tls.mbed.org/download/mbedtls-$pkgver-gpl.tgz"
-
-_builddir="$srcdir"/mbedtls-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="https://tls.mbed.org/download/$pkgname-$pkgver-gpl.tgz"
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
+
+ # this work-around is the same one used in Arch Linux's package
+ # see https://github.com/ARMmbed/mbedtls/issues/522
+ sed -i 's|<time.h>|"platform.h"|' include/mbedtls/ssl.h
+
# enable flags for non-embedded systems
sed -i -e 's|//\(#define MBEDTLS_THREADING_C\)|\1|' -e 's|//\(#define MBEDTLS_THREADING_PTHREAD\)|\1|' include/mbedtls/config.h
cmake . \
@@ -39,7 +34,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
@@ -55,6 +50,6 @@ static() {
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
}
-md5sums="b6909d94600fc5f644e9bca52e96fb27 mbedtls-2.2.1-gpl.tgz"
-sha256sums="bb1bffa3ac5ab143be2aae3d45a7a92b36112888ef465024d83724865fe62974 mbedtls-2.2.1-gpl.tgz"
-sha512sums="03c32b46369d35e61acfeac83f417d09307d2f1e4358f9ea6af275d9a9a2319ca7a244733b5950a48d59f6305e4adcad6a66e589b42ee7417d1d4362c2595a4f mbedtls-2.2.1-gpl.tgz"
+md5sums="3f396d21b9c86c0a11ac9ba0b6e6f999 mbedtls-2.3.0-gpl.tgz"
+sha256sums="21237014f779bde70b2d71399cc1ea53365eb7f10cdd74a13ee6329a1910cb49 mbedtls-2.3.0-gpl.tgz"
+sha512sums="f86ec87735b919e23ad7eb960a290013e7dfc2a5953d662ecee4eca7b990384c095aea74a313eaa0e1febb74e0c015879f4d680d51bc5eae811ab9e5063ba38a mbedtls-2.3.0-gpl.tgz"