aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2022-05-24 20:36:37 +0200
committeralice <alice@ayaya.dev>2022-05-24 22:31:16 +0000
commitf0b0872422672d562afd37b532371276a345671d (patch)
tree4797ce01e09ca72536f45e500e6c7552a322041d
parent0401721cad51d976d8c03c88b31128be57ae2be5 (diff)
testing/picolibc: upgrade to 1.7.7
-rw-r--r--testing/picolibc/APKBUILD16
-rw-r--r--testing/picolibc/a8ae5ad10df0b14c0b5ab34d7b67d25ede317bdb.patch40
2 files changed, 5 insertions, 51 deletions
diff --git a/testing/picolibc/APKBUILD b/testing/picolibc/APKBUILD
index fb92ba5ba3a..5ee7fb8ba8e 100644
--- a/testing/picolibc/APKBUILD
+++ b/testing/picolibc/APKBUILD
@@ -5,16 +5,15 @@ _targets="
riscv-none-elf
"
pkgname=picolibc
-pkgver=1.7.4
-pkgrel=2
+pkgver=1.7.7
+pkgrel=0
pkgdesc="A C standard library based on newlib with focus on compact size"
url="https://github.com/picolibc/picolibc"
makedepends="meson"
-# s390x and riscv64 blocked by gcc-cross-embedded
+# s390x blocked by gcc-cross-embedded
arch="all !s390x"
license="GPL-2.0-only AND LGPL-2.1-only AND 0BSD AND BSD-3-Clause AND GPL-3.0-only AND LGPL-3.0-only"
-source="$pkgname-$pkgver.tar.xz::https://github.com/picolibc/picolibc/releases/download/$pkgver/picolibc-$pkgver.tar.xz
- a8ae5ad10df0b14c0b5ab34d7b67d25ede317bdb.patch"
+source="$pkgname-$pkgver.tar.xz::https://github.com/picolibc/picolibc/releases/download/$pkgver/picolibc-$pkgver.tar.xz"
options="!check"
for target in $_targets; do
@@ -31,10 +30,6 @@ prepare() {
"$builddir/scripts/cross-riscv-none-elf.txt"
sed -e 's/riscv64-unknown-elf/riscv-none-elf/g' \
-i "$builddir/scripts/cross-riscv-none-elf.txt"
-
- # We don't really need bash
- find "$builddir/scripts" -type f -exec \
- sed -e 's|#!/bin/bash|#!/bin/sh|g' -i {} \;
}
build() {
@@ -75,6 +70,5 @@ riscv_none_elf() {
}
sha512sums="
-33fb67a23e36f3dd5934b6cf27d6dbb5abab5bd4439cb4d2c67c31750b590e198e7fc79363874bb775b109eddc636d6970e3cebabd0b857e9071cfcffc2ad351 picolibc-1.7.4.tar.xz
-3254abfb6d97ec6b8fdc23cae8c0d094d598155f9766ab1f40613721872d8a0a0b52385eab515b58da1ca521ec40c3e8e3166e1425c798d5674b9124af3fe72c a8ae5ad10df0b14c0b5ab34d7b67d25ede317bdb.patch
+afb8bd40601a0ecc46fffa15e23078d3a87b241212a48298f4d604ca482cba59dd3f0f7a7d4c7d69520d2b4261bb364da8fc4c46946c601c2423ab00920c08d9 picolibc-1.7.7.tar.xz
"
diff --git a/testing/picolibc/a8ae5ad10df0b14c0b5ab34d7b67d25ede317bdb.patch b/testing/picolibc/a8ae5ad10df0b14c0b5ab34d7b67d25ede317bdb.patch
deleted file mode 100644
index aa7981825c0..00000000000
--- a/testing/picolibc/a8ae5ad10df0b14c0b5ab34d7b67d25ede317bdb.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From a8ae5ad10df0b14c0b5ab34d7b67d25ede317bdb Mon Sep 17 00:00:00 2001
-From: Yasushi SHOJI <yashi@spacecubics.com>
-Date: Wed, 26 Jan 2022 14:53:56 +0900
-Subject: [PATCH] meson.build: Fix description keyword in configuration set()
-
-There are two typo for the keyword 'description' for config data set()
-in meson.build.
-
-Meson 0.61 doesn't warn about this but a post v0.61 with the
-commit mesonbuild/meson/commit/574525673f6 will error out with:
-
- meson.build:737:10: ERROR: configuration_data.set got unknown
- keyword arguments "descrption"
-
-This is reported by @tcal-x.
-
-Closes #244.
-
-Signed-off-by: Yasushi SHOJI <yashi@spacecubics.com>
----
- meson.build | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index f0d4c7c312..4f1c4ef2a9 100644
---- a/meson.build
-+++ b/meson.build
-@@ -736,10 +736,10 @@ conf_data.set('HAVE_BUILTIN_EXPECT', have_builtin_expect, description: 'Compiler
- conf_data.set('HAVE_ALLOC_SIZE', have_alloc_size, description: 'The compiler REALLY has the attribute __alloc_size__')
- conf_data.set('_HAVE_ATTRIBUTE_ALWAYS_INLINE',
- cc.has_function_attribute('always_inline'),
-- descrption: 'The compiler supports the always_inline function attribute')
-+ description: 'The compiler supports the always_inline function attribute')
- conf_data.set('_HAVE_ATTRIBUTE_GNU_INLINE',
- cc.has_function_attribute('gnu_inline'),
-- descrption: 'The compiler supports the gnu_inline function attribute')
-+ description: 'The compiler supports the gnu_inline function attribute')
-
- # Obsolete newlib options
- conf_data.set('_WANT_USE_LONG_TIME_T', get_option('newlib-long-time_t'), description: 'Obsoleted. Define time_t to long instead of using a 64-bit type')