aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorConsus <consus@ftml.net>2023-01-20 02:25:42 +0000
committerpsykose <alice@ayaya.dev>2023-01-20 03:25:53 +0100
commitf0c46707ed4b1d1245eb77d7ed56349caa1ae275 (patch)
tree65bb586446c42b30fe24e54e628c51a018e66c9e
parent746a7a2189b05944013c211b443e342098be574f (diff)
main/multipath-tools: fix filepaths
multipath-tools uses $configdir compile-time option that points to $(prefix)/etc/multipath, which is not what users generally expect. Also OpenRC service was broken and referring to /sbin/multipathd instead of /usr/sbin/multipathd.
-rw-r--r--main/multipath-tools/APKBUILD5
-rw-r--r--main/multipath-tools/multipathd.initd2
2 files changed, 4 insertions, 3 deletions
diff --git a/main/multipath-tools/APKBUILD b/main/multipath-tools/APKBUILD
index 68356a8e762..d9c17340635 100644
--- a/main/multipath-tools/APKBUILD
+++ b/main/multipath-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=multipath-tools
pkgver=0.9.4
-pkgrel=0
+pkgrel=1
pkgdesc="Device Mapper Multipathing Driver"
url="http://christophe.varoqui.free.fr/"
arch="all"
@@ -21,6 +21,7 @@ options="!check"
build() {
make prefix="/usr" \
sysconfdir="/etc" \
+ configdir="/etc/multipath/conf.d" \
mandir="/usr/share/man" \
infodir="/usr/share/info"
}
@@ -42,6 +43,6 @@ sha512sums="
5e0dcea610fc215e345444c04453a38f39c73e493c2bc53f6b3a90cd701266aabdf7c4693dfc321099af836d0019bf27355e265ad5db5deff48f8bb94ed4719d multipath-tools-0.9.4.tar.gz
e81462b22c0cbc92ea935d7544b9f9a0c4ccbcf13f3bc03dadf6de96407c9cf49964c9bbf02f12a134e1255c66421c6fde39d54b15eef975e8df81bdc88b2213 multipath-tools.conf
97deeee57daee787d807da0a4dbf50baae047ddcda30925f7000ec822b5a17a3dc55196c3e032c8ffbc2caeac690ce5ca485b0a7c99f15e66bddaa000439112a multipath.initd
-2f913fed199f12f048eb042b5bb1a326f6f09cfe63d572ac269461d96ebf25b251576de22be7ba9ab631ded7af6fd47dac38fda3b29d00640c806181eb37447c multipathd.initd
+71933b27a9ed76d00766ee29e0583ccf08bd689805cf77e284bc318bae62ad7bcde1894b2e50993019462b0c9787eaa780b271244ff11ef52cca290604900343 multipathd.initd
f5699633be498cc78ed27c222334b9e5c7271b852f9e687991e425a27db74cd9c01198792fe5fc7f5dedf47fee9b577e8c4803f5b0323b10544f3678d5c6c714 0001-Disable-Werror-and-O2.patch
"
diff --git a/main/multipath-tools/multipathd.initd b/main/multipath-tools/multipathd.initd
index 931ef46e8a6..ed5ec41e39a 100644
--- a/main/multipath-tools/multipathd.initd
+++ b/main/multipath-tools/multipathd.initd
@@ -1,7 +1,7 @@
#!/sbin/openrc-run
supervisor=supervise-daemon
-command=/sbin/multipathd
+command=/usr/sbin/multipathd
command_args_foreground="-d"
output_log=/var/log/${RC_SVCNAME}.log
error_log=/var/log/${RC_SVCNAME}.log