aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArda Aytekin <arda.aytekin@ericsson.com>2020-04-20 15:44:04 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-21 13:42:07 +0000
commitf1944ff773d0b4b6c188f2c7952123f0f758680c (patch)
tree354bbcfe93f7371995c2f24ba3fdb60b88ba8423
parentf0e34c7d9d925c923ae0e5727a7eecc91133d325 (diff)
community/openblas: revert LAPACK changes
Reverted back the changes in `community/openblas` introduced in bea9248f and 7fd6f743 to let `openblas` install the optimized version of LAPACK. See the discussion under #10739. Note. !7023 was merged before the cherry-picking got completed following the changes under !7022. This commit fixes it.
-rw-r--r--community/openblas/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/community/openblas/APKBUILD b/community/openblas/APKBUILD
index 3b29b2f245f..826c6e9738b 100644
--- a/community/openblas/APKBUILD
+++ b/community/openblas/APKBUILD
@@ -4,12 +4,12 @@
pkgname=openblas
_pkgname=OpenBLAS
pkgver=0.3.9
-pkgrel=1
+pkgrel=2
pkgdesc="A fast BSD-licensed BLAS based on gotoBLAS2, with LAPACK"
url="http://www.openblas.net"
arch="all !mips !mips64"
license="BSD-3-Clause"
-provides="blas lapack"
+replaces="blas lapack"
depends_dev="gfortran"
makedepends="$depends_dev perl linux-headers"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
@@ -75,6 +75,11 @@ build() {
fi
}
+dev() {
+ replaces="blas-dev lapack-dev"
+ default_dev
+}
+
check() {
CFLAGS= make $_flags CFLAGS="$CFLAGS" tests
}