aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-12-19 17:54:01 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-12-19 17:55:10 +0000
commitf2dbc05b56390b2009a4e0c8699e95d5b085c091 (patch)
tree5ae21fdca5dd7fdfdf8057acdab5d74b6669a28b
parent7c15f00b17c8d319ac636cf7c02b0fa128d5450a (diff)
community/elogind: fix build on mips(64)
`asm/sgidefs.h` is only included if `ARCH_MIPS` is defined, but this is apparently not the case. Check instead of `_MIPS_SIM` is defined.
-rw-r--r--community/elogind/APKBUILD4
-rw-r--r--community/elogind/fix-mips-detection.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/community/elogind/APKBUILD b/community/elogind/APKBUILD
index c6c3f912bac..bbc1dfe5ea5 100644
--- a/community/elogind/APKBUILD
+++ b/community/elogind/APKBUILD
@@ -39,6 +39,7 @@ subpackages="
"
source="https://github.com/elogind/elogind/archive/v$pkgver/elogind-v$pkgver.tar.gz
elogind.initd
+ fix-mips-detection.patch
"
build() {
@@ -94,4 +95,5 @@ bashcomp() {
}
sha512sums="639815ba3d97bce47ae4f7dadd0a6be63fd0d0a88425d30cc871efc9419b134945ecf0ba8e05656934fbc7a9248488f020c276ae51e23cabed4735e5654652a1 elogind-v246.9.tar.gz
-e73738488e78af099fdbb7c93a411a3e8d69080a93f89c245cb8c6de5fe4cb7fe724687d19e21eb6be52ccc795ec200d9c6e499efb1afd2b27467f7f541a7dd1 elogind.initd"
+e73738488e78af099fdbb7c93a411a3e8d69080a93f89c245cb8c6de5fe4cb7fe724687d19e21eb6be52ccc795ec200d9c6e499efb1afd2b27467f7f541a7dd1 elogind.initd
+0fda4318afc6db9c9d00121ed4f8267286e692cca04acf4c1006fab99267cdd6228e1d176293f99db043384ae6fa192fc8109a365bf221dda7f2c4177d104820 fix-mips-detection.patch"
diff --git a/community/elogind/fix-mips-detection.patch b/community/elogind/fix-mips-detection.patch
new file mode 100644
index 00000000000..37069471a76
--- /dev/null
+++ b/community/elogind/fix-mips-detection.patch
@@ -0,0 +1,13 @@
+diff --git a/src/basic/missing_syscall.h b/src/basic/missing_syscall.h
+index ccfa657..20ddb08 100644
+--- a/src/basic/missing_syscall.h
++++ b/src/basic/missing_syscall.h
+@@ -11,7 +11,7 @@
+ #include <sys/wait.h>
+ #include <unistd.h>
+
+-#ifdef ARCH_MIPS
++#ifdef _MIPS_SIM
+ #include <asm/sgidefs.h>
+ #endif
+