aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-03-20 04:01:17 +0000
committerpsykose <alice@ayaya.dev>2023-03-20 05:01:17 +0100
commitf3395e4d088d4256cca7c64f5f790fae23248b8a (patch)
tree1ea0b33ce4880449213d98c9f1cb2483d98e00f5
parent2919e57f8fd380dff223c30814a71aa1f28120ab (diff)
downloadaports-f3395e4d088d4256cca7c64f5f790fae23248b8a.tar.gz
aports-f3395e4d088d4256cca7c64f5f790fae23248b8a.tar.bz2
aports-f3395e4d088d4256cca7c64f5f790fae23248b8a.tar.xz
main/rsync: enable xxhash, reformat
the -DINET6 seems not needed anymore, xxhash is the fastest checksumming algorithm available to rsync
-rw-r--r--main/rsync/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/main/rsync/APKBUILD b/main/rsync/APKBUILD
index f6550f54d83..9545f65dd5b 100644
--- a/main/rsync/APKBUILD
+++ b/main/rsync/APKBUILD
@@ -1,13 +1,22 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rsync
pkgver=3.2.7
-pkgrel=0
+pkgrel=1
pkgdesc="A file transfer program to keep remote files in sync"
url="https://rsync.samba.org/"
arch="all"
license="GPL-3.0-or-later"
-makedepends="perl acl-dev attr-dev popt-dev zlib-dev zstd-dev lz4-dev"
-subpackages="$pkgname-doc $pkgname-openrc rrsync"
+makedepends="
+ acl-dev
+ attr-dev
+ lz4-dev
+ perl
+ popt-dev
+ xxhash-dev
+ zlib-dev
+ zstd-dev
+ "
+subpackages="$pkgname-doc $pkgname-openrc rrsync::noarch"
source="https://download.samba.org/pub/rsync/rsync-$pkgver.tar.gz
rsyncd.initd
rsyncd.confd
@@ -35,9 +44,7 @@ prepare() {
}
build() {
- # Force IPv6 enabled, upstream bug https://bugzilla.samba.org/show_bug.cgi?id=10715
- CFLAGS="$CFLAGS -DINET6" \
-
+ CFLAGS="$CFLAGS -flto=auto" \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -47,14 +54,11 @@ build() {
--localstatedir=/var \
--enable-acl-support \
--enable-xattr-support \
+ --enable-xxhash \
--without-included-popt \
--without-included-zlib \
- --disable-xxhash \
--disable-openssl
- # xxhash and openssl support were implicitly disabled before via automagic
- # since nobody complained that those features were missing starting with 3.2.x
- # they cause errors unless they are expilcitly disabled. If you need those
- # features then open a MR
+ # openssl is disabled since xxh checksums are faster anyway
make
}
@@ -69,15 +73,14 @@ package() {
install -Dm644 "$srcdir"/rsyncd.conf "$pkgdir"/etc/rsyncd.conf
install -Dm644 "$srcdir"/rsyncd.confd "$pkgdir"/etc/conf.d/rsyncd
install -Dm644 "$srcdir"/rsyncd.logrotate "$pkgdir"/etc/logrotate.d/rsyncd
+ install -Dm644 support/rrsync -t "$pkgdir"/usr/bin/
}
rrsync() {
pkgdesc="Restricted rsync, restricts rsync to a subdir declared in .ssh/authorized_keys"
depends="rsync python3"
- arch="noarch"
- cd "$builddir"
- install -D -m 755 ./support/rrsync "$subpkgdir"/usr/bin/rrsync
+ amove usr/bin/rrsync
}
sha512sums="