aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Zeni <simon@bl4ckb0ne.ca>2020-01-24 23:51:22 -0500
committerKevin Daudt <kdaudt@alpinelinux.org>2020-01-25 16:03:35 +0000
commitf3fafe62cb3fa56d6f2ae9cfec5f48ea3043d5b4 (patch)
treee05e8afa6952f9e0c6736d8bc1ef33f3b50099e7
parentabcc140e83b8378d5499dd00fbf63764c22af5b4 (diff)
testing/waypipe: new aports
https://gitlab.freedesktop.org/mstoeckl/waypipe A proxy for Wayland protocol applications.
-rw-r--r--testing/waypipe/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/waypipe/APKBUILD b/testing/waypipe/APKBUILD
new file mode 100644
index 00000000000..a095b4b63c9
--- /dev/null
+++ b/testing/waypipe/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Simon Zeni <simon@bl4ckb0ne.ca>
+# Maintainer: Simon Zeni <simon@bl4ckb0ne.ca>
+pkgname="waypipe"
+pkgver="0.6.1"
+pkgrel=0
+pkgdesc="A proxy for Wayland protocol applications."
+url="https://gitlab.freedesktop.org/mstoeckl/waypipe"
+arch="all"
+license="MIT"
+makedepends="meson wayland-protocols wayland-dev scdoc cmake lz4-dev mesa-gbm libdrm-dev libva-dev"
+source="https://gitlab.freedesktop.org/mstoeckl/waypipe/-/archive/v$pkgver/waypipe-v$pkgver.tar.gz"
+options="!check"
+builddir="$srcdir/$pkgname-v$pkgver"
+subpackages="$pkgname-doc"
+
+prepare() {
+ meson build \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ -Dwerror=false \
+ -Db_ndebug=true
+}
+
+build() {
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+sha512sums="7b7cdc6d808f8f9e3720425af6ca1a75b81ffadc990e181f52940320efab6d5c6b55dcc10adb36c90b784426a71fab2a037206f4cb2634775628b52dc27cb830 waypipe-v0.6.1.tar.gz"