aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2019-10-23 15:10:32 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-23 18:38:56 -0300
commitf449efd318906e76343dd3a337b2a4e9b3e6f207 (patch)
tree8a0237a5f7ce5b34f21080937f81d4c26761c783
parenta255fa64a3a126dba7ab9beed9078732db97e8f0 (diff)
testing/py3-wxpython: Fixed file permissions
Some of the installed python files are installed with permissions 600, so that (non-root) users cannot load the module properly. The fix was is almost copied in verbatim from Arch Linux.
-rw-r--r--testing/py3-wxpython/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/testing/py3-wxpython/APKBUILD b/testing/py3-wxpython/APKBUILD
index 091559325d8..28bd586a549 100644
--- a/testing/py3-wxpython/APKBUILD
+++ b/testing/py3-wxpython/APKBUILD
@@ -3,7 +3,7 @@
_pkgname=wxPython
pkgname=py3-wxpython
pkgver=4.0.6
-pkgrel=0
+pkgrel=1
pkgdesc="Cross-platform GUI toolkit for the Python language"
url="https://wxpython.org/"
arch="all"
@@ -35,6 +35,7 @@ check() {
package() {
python3 build.py install --destdir="$pkgdir"
install -Dm 644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+ find "$pkgdir"/usr/lib -type f -exec chmod 644 {} \;
}
sha512sums="bfe799e1a0987cb57f2e31199cdb522471aaa08bb3b642fdf4130f4219b81487d4b6252f7a8afd3af7cdaeef2e992cecfc581e97d8b42307a4e0a8c9009db301 wxPython-4.0.6.tar.gz"