aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2021-04-28 22:42:01 +0200
committerJakub Jirutka <jakub@jirutka.cz>2021-04-28 22:42:32 +0200
commitf612460f28912e5037d7ca7541706351ff4ccf7a (patch)
tree103f628f41e58e19664f9f31ac0cd3c286af45c0
parentfa5ad400ad0767a9bbe36077eaadd5fd3a3a3bb0 (diff)
community/weasyprint: upgrade to 52.5
-rw-r--r--community/weasyprint/APKBUILD8
-rw-r--r--community/weasyprint/fix-pango-update-font-map.patch35
2 files changed, 3 insertions, 40 deletions
diff --git a/community/weasyprint/APKBUILD b/community/weasyprint/APKBUILD
index cd8f05d5871..c78caf5a377 100644
--- a/community/weasyprint/APKBUILD
+++ b/community/weasyprint/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=weasyprint
_pyname=WeasyPrint
-pkgver=52.4
-pkgrel=2
+pkgver=52.5
+pkgrel=0
pkgdesc="A visual rendering engine for HTML and CSS that can export to PDF"
url="https://weasyprint.org"
arch="noarch"
@@ -30,7 +30,6 @@ makedepends="py3-setuptools py3-pytest-runner"
replaces="py-weasyprint py3-weasyprint" # for backward compatibility
provides="py-weasyprint=$pkgver-r$pkgrel py3-weasyprint=$pkgver-r$pkgrel" # for backward compatibility
source="https://files.pythonhosted.org/packages/source/W/$_pyname/$_pyname-$pkgver.tar.gz
- fix-pango-update-font-map.patch
disable-flake8-isort-for-pytest.patch
dont-install-tests.patch
"
@@ -53,7 +52,6 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0003f9b46452e60118e7f6944f0bf48b6f548814dae10f990bedb124d3c67d9c530c30ee142d416f448b3b479f54b4fcdf01e31747957438192c77031926cb8c WeasyPrint-52.4.tar.gz
-9c1c75c7eaaa9e3ded23950760bc94fc98881c10c1cb4e3e46a299cd3f26221d5350535eefff2969624954a069c22799604f7e3433fbe97f381274a65392d415 fix-pango-update-font-map.patch
+sha512sums="0ce86db000adef95fabfb335c069ad2a602ed98056219cedde905c550b04b10b0881d72fbdd38a48fae4e263825f5fbd8a70ce13932083afb8930eacc5817fb5 WeasyPrint-52.5.tar.gz
39cd6c96804977913e2f83a1f1b6f606c54ed68eeb7c3aa08dfecf33a725b840a6234f6635a2eea6dc4af61818222b6a08eb745f6b37c73c80c3923d7ebcd30a disable-flake8-isort-for-pytest.patch
f3477df116105c993330359cff9076e75b385a8f88addb85b2a03977d5e2c709ac46355bff555a296a8cb674a1e22f377090a413491f41cb6d40c80ab17f72cc dont-install-tests.patch"
diff --git a/community/weasyprint/fix-pango-update-font-map.patch b/community/weasyprint/fix-pango-update-font-map.patch
deleted file mode 100644
index 9b77a365daa..00000000000
--- a/community/weasyprint/fix-pango-update-font-map.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 47043a1fd7e50a892b9836466f521df85d597c44 Mon Sep 17 00:00:00 2001
-From: Guillaume Ayoub <guillaume@courtbouillon.org>
-Date: Sat, 13 Mar 2021 13:34:28 +0100
-Subject: [PATCH] Update the font map when the font config has changed
-
-Needed because of a bug fix in Pango 1.48.3. See
-https://gitlab.gnome.org/GNOME/pango/-/commit/3fc7b26.
----
- weasyprint/fonts.py | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/weasyprint/fonts.py b/weasyprint/fonts.py
-index 79e3b5bbc..859df57fa 100644
---- a/weasyprint/fonts.py
-+++ b/weasyprint/fonts.py
-@@ -115,6 +115,7 @@ def add_font_face(self, rule_descriptors, url_fetcher):
- void pango_fc_font_map_set_config (
- PangoFcFontMap *fcfontmap, FcConfig *fcconfig);
- void pango_fc_font_map_shutdown (PangoFcFontMap *fcfontmap);
-+ void pango_fc_font_map_config_changed (PangoFcFontMap *fcfontmap);
-
-
- // PangoCairo
-@@ -428,9 +429,8 @@ def add_font_face(self, rule_descriptors, url_fetcher):
- if font_added:
- # TODO: We should mask local fonts with the same name
- # too as explained in Behdad's blog entry.
-- # TODO: What about pango_fc_font_map_config_changed()
-- # as suggested in Behdad's blog entry?
-- # Though it seems to work without…
-+ pangoft2.pango_fc_font_map_config_changed(
-+ ffi.cast('PangoFcFontMap *', self.font_map))
- return font_filename
- else:
- LOGGER.debug('Failed to load font at "%s"', url)