aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-18 22:09:24 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-24 11:46:42 +0000
commitf72adbbfcc154cbeae25f6496b0857d2e414b4ec (patch)
treeb7b23c087176ec53e8f7b7604908fe16737db05a
parent466d105b8020dd27c0160a36a0ca5c248482dac6 (diff)
community/kookbook: move from testing and take over maintainership
-rw-r--r--community/kookbook/APKBUILD (renamed from testing/kookbook/APKBUILD)21
1 files changed, 7 insertions, 14 deletions
diff --git a/testing/kookbook/APKBUILD b/community/kookbook/APKBUILD
index d171927627c..8aea0b7cfb8 100644
--- a/testing/kookbook/APKBUILD
+++ b/community/kookbook/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Luca Weiss <luca@z3ntu.xyz>
-# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kookbook
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple recipe manager taking structured markdown for recipes"
url="https://github.com/KDE/kookbook/blob/master/doc/intro.md"
arch="all !armhf"
@@ -14,22 +14,15 @@ source="https://download.kde.org/unstable/kookbook/kookbook-$pkgver.tar.xz"
options="!check" # No tests
build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS} .
- make
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
common() {