aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-06-29 02:10:30 +0000
committerpsykose <alice@ayaya.dev>2023-06-29 04:10:30 +0200
commitf8276a664f0d2932b39d1838335d1a4baf38b618 (patch)
tree07c7d752eb7b0b1f5b35cc77c86295bc4110cae6
parent113470591c28751d2af86de5cb5566bc8401f909 (diff)
testing/faust: fix renamed usage.sh and some coreutils expectations
-rw-r--r--testing/faust/APKBUILD9
-rw-r--r--testing/faust/busybox.patch28
-rw-r--r--testing/faust/usage.patch866
3 files changed, 901 insertions, 2 deletions
diff --git a/testing/faust/APKBUILD b/testing/faust/APKBUILD
index a1eb1c15ccb..f585a26c498 100644
--- a/testing/faust/APKBUILD
+++ b/testing/faust/APKBUILD
@@ -2,12 +2,14 @@
# Maintainer: Francesco Camuffo <dev@fmac.xyz>
pkgname=faust
pkgver=2.60.3
-pkgrel=1
+pkgrel=2
_llvmver=16
pkgdesc="Functional programming language for realtime audio signal processing"
url="https://faust.grame.fr"
arch="all"
license="GPL-2.0-or-later"
+# all faust* tools are bash
+depends="bash"
depends_dev="$pkgname-tools=$pkgver-r$pkgrel"
makedepends="
cmake
@@ -16,7 +18,6 @@ makedepends="
llvm$_llvmver-dev
samurai
"
-checkdepends="bash"
subpackages="
$pkgname-tools
$pkgname-static
@@ -25,8 +26,10 @@ subpackages="
$pkgname-vim::noarch
"
source="$pkgname-$pkgver.tar.gz::https://github.com/grame-cncm/faust/releases/download/$pkgver/faust-$pkgver.tar.gz
+ busybox.patch
gcc13.patch
no-execinfo.patch
+ usage.patch
"
prepare() {
@@ -107,6 +110,8 @@ vim() {
sha512sums="
cdb31a519f5615ecdb36336d67de524b10acfc6e5449fea1a5a154a37d29f028c3db1ac0ba5f3bb9e0a39e00057397724dd5ad711fbab2ceacfb4cc1dee3e011 faust-2.60.3.tar.gz
+2e2aae4b3fe760e41b3a9b1b82edc9cfac674944efb41c296e1c71f80763cbadc72544e0cbd7f5048095322779c3d432838ea66d32376a29b95bb08fe8c25e96 busybox.patch
edb822664f2277e58af82f6e339668c11a822880928646fddc21f4c245e81b70f9bc5e2892008dfe5c56a23b46aa50c40607f6ccca3a42029b7a21b0bf317302 gcc13.patch
fb1ef67a0c1ba56ba98e5c85935566c263a7b51a44c8ffd1789f7379b9bd14cbb2b373392e70c1c9974163559dbed910be3af64ccd3198633758998dee5c7bb2 no-execinfo.patch
+ac45a55400970952daf7918f48b3d13efd06d5b3ffc1fa41e71d83eb3f53b31031fec353ab74e40c66667dbc3c6b32b2b38249a7e85c890221374cada38d4285 usage.patch
"
diff --git a/testing/faust/busybox.patch b/testing/faust/busybox.patch
new file mode 100644
index 00000000000..9e632dfdd61
--- /dev/null
+++ b/testing/faust/busybox.patch
@@ -0,0 +1,28 @@
+ls -f doesn't exist so just pass the install location
+--
+diff --git a/tools/faust2appls/faust2lv2 b/tools/faust2appls/faust2lv2
+index 8fa948f..7527385 100755
+--- a/tools/faust2appls/faust2lv2
++++ b/tools/faust2appls/faust2lv2
+@@ -21,7 +21,7 @@
+ # that you can run the script from the faust-lv2 source directory. You can
+ # also specify this explicitly by setting the FAUSTLIB environment variable
+ # accordingly.
+-[ -z "$FAUSTLIB" ] && FAUSTLIB=$(dirname "$((ls -f /usr/share/faust/lv2ui.cpp /usr/local/share/faust/lv2ui.cpp /opt/local/share/faust/lv2ui.cpp "$PWD/lv2ui.cpp" 2>/dev/null)|tail -1)")
++[ -z "$FAUSTLIB" ] && FAUSTLIB=/usr/share/faust
+ [ -z "$FAUSTLIB" ] && FAUSTLIB="$PWD"
+
+ # defaults (these can be changed with the options listed below)
+diff --git a/tools/faust2appls/faust2pure b/tools/faust2appls/faust2pure
+index 265e4c4..e50478d 100755
+--- a/tools/faust2appls/faust2pure
++++ b/tools/faust2appls/faust2pure
+@@ -6,7 +6,7 @@
+ # locations here, and fall back to the current directory if the file isn't
+ # found. You can also specify this explicitly by setting the FAUSTLIB
+ # environment variable accordingly.
+-[ -z "$FAUSTLIB" ] && FAUSTLIB=$(dirname "$((ls -f /usr/share/faust/pure.cpp /usr/local/share/faust/pure.cpp /opt/local/share/faust/pure.cpp "$PWD/pure.cpp" 2>/dev/null)|tail -1)")
++[ -z "$FAUSTLIB" ] && FAUSTLIB=/usr/share/faust
+ [ -z "$FAUSTLIB" ] && FAUSTLIB="$PWD"
+
+ # defaults (these can be changed with the options listed below)
diff --git a/testing/faust/usage.patch b/testing/faust/usage.patch
new file mode 100644
index 00000000000..e6c656a70f3
--- /dev/null
+++ b/testing/faust/usage.patch
@@ -0,0 +1,866 @@
+diff --git a/tools/faust2appls/faust2alqt b/tools/faust2appls/faust2alqt
+index 0f58c39..0656b82 100755
+--- a/tools/faust2appls/faust2alqt
++++ b/tools/faust2appls/faust2alqt
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2alsa b/tools/faust2appls/faust2alsa
+index 94aded2..4e1ba48 100755
+--- a/tools/faust2appls/faust2alsa
++++ b/tools/faust2appls/faust2alsa
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2alsaconsole b/tools/faust2appls/faust2alsaconsole
+index 5117820..fea650c 100755
+--- a/tools/faust2appls/faust2alsaconsole
++++ b/tools/faust2appls/faust2alsaconsole
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2android b/tools/faust2appls/faust2android
+index d9013ce..c901554 100755
+--- a/tools/faust2appls/faust2android
++++ b/tools/faust2appls/faust2android
+@@ -10,7 +10,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ # change if you want to get the log of what's happening
+ LOG="/dev/null"
+diff --git a/tools/faust2appls/faust2androidunity b/tools/faust2appls/faust2androidunity
+index 646402c..13c2168 100755
+--- a/tools/faust2appls/faust2androidunity
++++ b/tools/faust2appls/faust2androidunity
+@@ -17,7 +17,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2api b/tools/faust2appls/faust2api
+index 3871ce6..16d9d2a 100755
+--- a/tools/faust2appls/faust2api
++++ b/tools/faust2appls/faust2api
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2au b/tools/faust2appls/faust2au
+index 1050986..17c5f96 100755
+--- a/tools/faust2appls/faust2au
++++ b/tools/faust2appls/faust2au
+@@ -6,7 +6,7 @@
+ # (c) Grame 2013
+ #
+ #####################################################################
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2audiokit b/tools/faust2appls/faust2audiokit
+index fbb209b..7ac5bf0 100755
+--- a/tools/faust2appls/faust2audiokit
++++ b/tools/faust2appls/faust2audiokit
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2bela b/tools/faust2appls/faust2bela
+index a5480f2..42811ba 100755
+--- a/tools/faust2appls/faust2bela
++++ b/tools/faust2appls/faust2bela
+@@ -1,7 +1,7 @@
+ #!/bin/bash -e
+
+ . faustpath
+-. usage.sh
++. faust-usage.sh
+
+ #FAUST DATA:
+ [ -z "$ARCHFILE" ] && ARCHFILE=$FAUSTARCH/bela.cpp
+diff --git a/tools/faust2appls/faust2bench b/tools/faust2appls/faust2bench
+index aecbfb3..bc27eb9 100755
+--- a/tools/faust2appls/faust2bench
++++ b/tools/faust2appls/faust2bench
+@@ -14,7 +14,7 @@
+ . faustoptflags
+
+ # Helper file to build the 'help' option
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2cagtk b/tools/faust2appls/faust2cagtk
+index 59084a4..7e859ff 100755
+--- a/tools/faust2appls/faust2cagtk
++++ b/tools/faust2appls/faust2cagtk
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS -I/opt/local/include" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2caqt b/tools/faust2appls/faust2caqt
+index d106fbe..d6bbebe 100755
+--- a/tools/faust2appls/faust2caqt
++++ b/tools/faust2appls/faust2caqt
+@@ -11,7 +11,7 @@ set -e
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2caqtios b/tools/faust2appls/faust2caqtios
+index 7fe3b0e..035987c 100755
+--- a/tools/faust2appls/faust2caqtios
++++ b/tools/faust2appls/faust2caqtios
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ #. faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS -DIOS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2cmajor b/tools/faust2appls/faust2cmajor
+index 2863bee..a2ceb29 100755
+--- a/tools/faust2appls/faust2cmajor
++++ b/tools/faust2appls/faust2cmajor
+@@ -10,7 +10,7 @@ set -e
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ ARCHFILE=$FAUSTARCH/cmajor/minimal.cmajor
+
+diff --git a/tools/faust2appls/faust2cpalrust b/tools/faust2appls/faust2cpalrust
+index ee4a7b4..8c3ca57 100755
+--- a/tools/faust2appls/faust2cpalrust
++++ b/tools/faust2appls/faust2cpalrust
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ SRC="0"
+ ARCHFILE=$FAUSTARCH/cpal.rs
+diff --git a/tools/faust2appls/faust2csound b/tools/faust2appls/faust2csound
+index 6e2ffc9..43da77e 100755
+--- a/tools/faust2appls/faust2csound
++++ b/tools/faust2appls/faust2csound
+@@ -10,7 +10,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2csvplot b/tools/faust2appls/faust2csvplot
+index cb8cd5b..30460ef 100755
+--- a/tools/faust2appls/faust2csvplot
++++ b/tools/faust2appls/faust2csvplot
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2daisy b/tools/faust2appls/faust2daisy
+index 0e71217..a173a5d 100755
+--- a/tools/faust2appls/faust2daisy
++++ b/tools/faust2appls/faust2daisy
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2dplug b/tools/faust2appls/faust2dplug
+index 39a4b5b..d4d572b 100755
+--- a/tools/faust2appls/faust2dplug
++++ b/tools/faust2appls/faust2dplug
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ DEBUG=false
+
+diff --git a/tools/faust2appls/faust2dssi b/tools/faust2appls/faust2dssi
+index d7b6b7a..390f934 100755
+--- a/tools/faust2appls/faust2dssi
++++ b/tools/faust2appls/faust2dssi
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2dummy b/tools/faust2appls/faust2dummy
+index edd7a79..446616e 100755
+--- a/tools/faust2appls/faust2dummy
++++ b/tools/faust2appls/faust2dummy
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2esp32 b/tools/faust2appls/faust2esp32
+index e0c5624..4564f07 100755
+--- a/tools/faust2appls/faust2esp32
++++ b/tools/faust2appls/faust2esp32
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ # change if you want to get the log of what's happening
+ LOG="/dev/null"
+diff --git a/tools/faust2appls/faust2faustvst b/tools/faust2appls/faust2faustvst
+index 0fa66b2..15822ee 100755
+--- a/tools/faust2appls/faust2faustvst
++++ b/tools/faust2appls/faust2faustvst
+@@ -4,7 +4,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ # Check for some common locations of the VST SDK files. This falls back to
+ # /usr/local/src/vstsdk if none of these are found. In that case, or if make
+diff --git a/tools/faust2appls/faust2feh b/tools/faust2appls/faust2feh
+index a76e671..f61e112 100755
+--- a/tools/faust2appls/faust2feh
++++ b/tools/faust2appls/faust2feh
+@@ -1,6 +1,6 @@
+ #! /bin/bash -e
+
+-. usage.sh
++. faust-usage.sh
+
+ if [[ $@ = "-help" ]] || [[ $@ = "-h" ]]; then
+ usage faust2feh "<file.dsp>"
+diff --git a/tools/faust2appls/faust2firefox b/tools/faust2appls/faust2firefox
+index 7ab5ea9..5f30052 100755
+--- a/tools/faust2appls/faust2firefox
++++ b/tools/faust2appls/faust2firefox
+@@ -1,6 +1,6 @@
+ #! /bin/bash -e
+
+-. usage.sh
++. faust-usage.sh
+
+ VIEWER_LAUNCH=${FAUST2FIREFOX_VIEWER_LAUNCH}
+ if [[ -z "${VIEWER_LAUNCH}" ]]; then
+diff --git a/tools/faust2appls/faust2gen b/tools/faust2appls/faust2gen
+index d0ef58d..9eddb5a 100755
+--- a/tools/faust2appls/faust2gen
++++ b/tools/faust2appls/faust2gen
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ POLY="MONO"
+ NVOICES=-1
+diff --git a/tools/faust2appls/faust2graph b/tools/faust2appls/faust2graph
+index ee58a1a..d27e358 100755
+--- a/tools/faust2appls/faust2graph
++++ b/tools/faust2appls/faust2graph
+@@ -3,7 +3,7 @@
+ # usage : faust2graph foo.dsp -> foo-sig.pdf
+ # usage : faust2graph -svg foo.dsp -> foo-sig.svg
+
+-. usage.sh
++. faust-usage.sh
+
+ FILES=""
+ IGNORE=""
+diff --git a/tools/faust2appls/faust2ios b/tools/faust2appls/faust2ios
+index e96ab71..ca8811d 100755
+--- a/tools/faust2appls/faust2ios
++++ b/tools/faust2appls/faust2ios
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ ARCHFILE=$FAUSTARCH/ios-coreaudio.cpp
+
+diff --git a/tools/faust2appls/faust2jack b/tools/faust2appls/faust2jack
+index 2a7e36c..f023ca3 100755
+--- a/tools/faust2appls/faust2jack
++++ b/tools/faust2appls/faust2jack
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS -I/opt/local/include" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2jackconsole b/tools/faust2appls/faust2jackconsole
+index 95fb259..dff4665 100755
+--- a/tools/faust2appls/faust2jackconsole
++++ b/tools/faust2appls/faust2jackconsole
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2jackrust b/tools/faust2appls/faust2jackrust
+index 4be4051..4475b82 100755
+--- a/tools/faust2appls/faust2jackrust
++++ b/tools/faust2appls/faust2jackrust
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ SRC="0"
+ ARCHFILE=$FAUSTARCH/jack.rs
+diff --git a/tools/faust2appls/faust2jackserver b/tools/faust2appls/faust2jackserver
+index 35e99c3..39deb1a 100755
+--- a/tools/faust2appls/faust2jackserver
++++ b/tools/faust2appls/faust2jackserver
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2jaqt b/tools/faust2appls/faust2jaqt
+index a92e1fd..80b0f98 100755
+--- a/tools/faust2appls/faust2jaqt
++++ b/tools/faust2appls/faust2jaqt
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2jaqtchain b/tools/faust2appls/faust2jaqtchain
+index 9c880f9..cd058ea 100755
+--- a/tools/faust2appls/faust2jaqtchain
++++ b/tools/faust2appls/faust2jaqtchain
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2juce b/tools/faust2appls/faust2juce
+index f35f88f..bf0e3d0 100755
+--- a/tools/faust2appls/faust2juce
++++ b/tools/faust2appls/faust2juce
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2ladspa b/tools/faust2appls/faust2ladspa
+index d48c3af..465db4d 100755
+--- a/tools/faust2appls/faust2ladspa
++++ b/tools/faust2appls/faust2ladspa
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2linuxunity b/tools/faust2appls/faust2linuxunity
+index b8ba4e6..6eaa52b 100755
+--- a/tools/faust2appls/faust2linuxunity
++++ b/tools/faust2appls/faust2linuxunity
+@@ -16,7 +16,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2lv2 b/tools/faust2appls/faust2lv2
+index 1fbb4b4..8fa948f 100755
+--- a/tools/faust2appls/faust2lv2
++++ b/tools/faust2appls/faust2lv2
+@@ -2,7 +2,7 @@
+
+ #set -x
+
+-. usage.sh
++. faust-usage.sh
+
+ # Default qmake setup (for GUI compilation). This requires Qt4 or Qt5 (Qt5 is
+ # preferred). We try to locate the qmake executable in some common locations
+diff --git a/tools/faust2appls/faust2mathdoc b/tools/faust2appls/faust2mathdoc
+index 4c9fdb9..0d19958 100755
+--- a/tools/faust2appls/faust2mathdoc
++++ b/tools/faust2appls/faust2mathdoc
+@@ -1,6 +1,6 @@
+ #! /bin/bash -e
+
+-. usage.sh
++. faust-usage.sh
+
+ # faust2mathdoc.sh
+ #
+diff --git a/tools/faust2appls/faust2max6 b/tools/faust2appls/faust2max6
+index fd45509..5e7a5e3 100755
+--- a/tools/faust2appls/faust2max6
++++ b/tools/faust2appls/faust2max6
+@@ -11,7 +11,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGSGENERIC" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2minimal b/tools/faust2appls/faust2minimal
+index 9c280c3..02b5620 100755
+--- a/tools/faust2appls/faust2minimal
++++ b/tools/faust2appls/faust2minimal
+@@ -14,7 +14,7 @@
+ . faustoptflags
+
+ # Helper file to build the 'help' option
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+ LIBADD+=" -pthread"
+diff --git a/tools/faust2appls/faust2msp b/tools/faust2appls/faust2msp
+index 5c0138b..e5191f9 100755
+--- a/tools/faust2appls/faust2msp
++++ b/tools/faust2appls/faust2msp
+@@ -10,7 +10,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGSGENERIC" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2netjackconsole b/tools/faust2appls/faust2netjackconsole
+index 71f9d70..12e3507 100755
+--- a/tools/faust2appls/faust2netjackconsole
++++ b/tools/faust2appls/faust2netjackconsole
+@@ -2,7 +2,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2netjackqt b/tools/faust2appls/faust2netjackqt
+index 9222492..158ed86 100755
+--- a/tools/faust2appls/faust2netjackqt
++++ b/tools/faust2appls/faust2netjackqt
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2nodejs b/tools/faust2appls/faust2nodejs
+index 1451fc5..7f549b4 100755
+--- a/tools/faust2appls/faust2nodejs
++++ b/tools/faust2appls/faust2nodejs
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ # exit if a command fails
+ set -e
+diff --git a/tools/faust2appls/faust2osxiosunity b/tools/faust2appls/faust2osxiosunity
+index 90a243f..0ed5ff0 100755
+--- a/tools/faust2appls/faust2osxiosunity
++++ b/tools/faust2appls/faust2osxiosunity
+@@ -27,7 +27,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2paqt b/tools/faust2appls/faust2paqt
+index 7036f8f..163d538 100755
+--- a/tools/faust2appls/faust2paqt
++++ b/tools/faust2appls/faust2paqt
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2plot b/tools/faust2appls/faust2plot
+index 55470f2..3301c9c 100755
+--- a/tools/faust2appls/faust2plot
++++ b/tools/faust2appls/faust2plot
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2portaudiojulia b/tools/faust2appls/faust2portaudiojulia
+index 3ddc32e..5a93ea9 100755
+--- a/tools/faust2appls/faust2portaudiojulia
++++ b/tools/faust2appls/faust2portaudiojulia
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ SRC="0"
+ ARCHFILE=$FAUSTARCH/julia/portaudio-gtk.jl
+diff --git a/tools/faust2appls/faust2portaudiorust b/tools/faust2appls/faust2portaudiorust
+index 6afae5c..c641151 100755
+--- a/tools/faust2appls/faust2portaudiorust
++++ b/tools/faust2appls/faust2portaudiorust
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ SRC="0"
+ ARCHFILE=$FAUSTARCH/portaudio.rs
+diff --git a/tools/faust2appls/faust2puredata b/tools/faust2appls/faust2puredata
+index dfb79a6..cea01fe 100755
+--- a/tools/faust2appls/faust2puredata
++++ b/tools/faust2appls/faust2puredata
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2raqt b/tools/faust2appls/faust2raqt
+index 014df7d..fc1ef13 100755
+--- a/tools/faust2appls/faust2raqt
++++ b/tools/faust2appls/faust2raqt
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2rpialsaconsole b/tools/faust2appls/faust2rpialsaconsole
+index aec2246..699813a 100755
+--- a/tools/faust2appls/faust2rpialsaconsole
++++ b/tools/faust2appls/faust2rpialsaconsole
+@@ -11,7 +11,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ ARCHFILE=$FAUSTARCH/alsa-console.cpp
+
+diff --git a/tools/faust2appls/faust2rpinetjackconsole b/tools/faust2appls/faust2rpinetjackconsole
+index 7576f00..2c556e3 100755
+--- a/tools/faust2appls/faust2rpinetjackconsole
++++ b/tools/faust2appls/faust2rpinetjackconsole
+@@ -11,7 +11,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ ARCHFILE=$FAUSTARCH/netjack-console.cpp
+
+diff --git a/tools/faust2appls/faust2sam b/tools/faust2appls/faust2sam
+index a08e507..627e554 100755
+--- a/tools/faust2appls/faust2sam
++++ b/tools/faust2appls/faust2sam
+@@ -12,7 +12,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ # change if you want to get the log of what's happening
+ LOG="/dev/null"
+diff --git a/tools/faust2appls/faust2sig b/tools/faust2appls/faust2sig
+index 651cca4..36feebc 100755
+--- a/tools/faust2appls/faust2sig
++++ b/tools/faust2appls/faust2sig
+@@ -3,7 +3,7 @@
+ # usage : faust2sig foo.dsp -> foo-sig.pdf
+ # usage : faust2sig -svg foo.dsp -> foo-sig.svg
+
+-. usage.sh
++. faust-usage.sh
+
+ echoHelp()
+ {
+diff --git a/tools/faust2appls/faust2smartkeyb b/tools/faust2appls/faust2smartkeyb
+index c297571..e5f2d18 100755
+--- a/tools/faust2appls/faust2smartkeyb
++++ b/tools/faust2appls/faust2smartkeyb
+@@ -8,7 +8,7 @@
+ #####################################################################
+
+ . faustpath
+-. usage.sh
++. faust-usage.sh
+
+ # change if you want to get the log of what's happening
+ LOG="/dev/null"
+diff --git a/tools/faust2appls/faust2sndfile b/tools/faust2appls/faust2sndfile
+index a47f3c1..831871e 100755
+--- a/tools/faust2appls/faust2sndfile
++++ b/tools/faust2appls/faust2sndfile
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2svg b/tools/faust2appls/faust2svg
+index 01df452..2ef49e6 100755
+--- a/tools/faust2appls/faust2svg
++++ b/tools/faust2appls/faust2svg
+@@ -1,6 +1,6 @@
+ #! /bin/bash -e
+
+-. usage.sh
++. faust-usage.sh
+
+ echoHelp()
+ {
+diff --git a/tools/faust2appls/faust2teensy b/tools/faust2appls/faust2teensy
+index 77536a1..ac51411 100755
+--- a/tools/faust2appls/faust2teensy
++++ b/tools/faust2appls/faust2teensy
+@@ -8,7 +8,7 @@
+ #####################################################################
+
+ . faustpath
+-. usage.sh
++. faust-usage.sh
+
+ # change if you want to get the log of what's happening
+ LOG="/dev/null"
+diff --git a/tools/faust2appls/faust2unity b/tools/faust2appls/faust2unity
+index a4e7231..0e395d4 100755
+--- a/tools/faust2appls/faust2unity
++++ b/tools/faust2appls/faust2unity
+@@ -18,7 +18,7 @@
+ # Several options are available, see architecture/unity/README.md for more info.
+
+ . faustpath
+-. usage.sh
++. faust-usage.sh
+
+ echoHelp()
+ {
+diff --git a/tools/faust2appls/faust2vcvrack b/tools/faust2appls/faust2vcvrack
+index 581a9bc..453cd36 100755
+--- a/tools/faust2appls/faust2vcvrack
++++ b/tools/faust2appls/faust2vcvrack
+@@ -9,7 +9,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+
+diff --git a/tools/faust2appls/faust2wasm b/tools/faust2appls/faust2wasm
+index 98b18a4..414fcac 100755
+--- a/tools/faust2appls/faust2wasm
++++ b/tools/faust2appls/faust2wasm
+@@ -2,7 +2,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ #-------------------------------------------------------------------
+ # Wrapping resources
+diff --git a/tools/faust2appls/faust2webaudiowasm b/tools/faust2appls/faust2webaudiowasm
+index c34e3cd..745eaa5 100755
+--- a/tools/faust2appls/faust2webaudiowasm
++++ b/tools/faust2appls/faust2webaudiowasm
+@@ -2,7 +2,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ #-------------------------------------------------------------------
+ # Wrapping resources
+diff --git a/tools/faust2appls/faust2webaudiowast b/tools/faust2appls/faust2webaudiowast
+index fc8c649..ba6af2a 100755
+--- a/tools/faust2appls/faust2webaudiowast
++++ b/tools/faust2appls/faust2webaudiowast
+@@ -2,7 +2,7 @@
+
+ . faustpath
+ . faustoptflags
+-. usage.sh
++. faust-usage.sh
+
+ #-------------------------------------------------------------------
+ # Wrapping resources
+diff --git a/tools/faust2appls/faust2winunity b/tools/faust2appls/faust2winunity
+index bdb24c1..08ed834 100755
+--- a/tools/faust2appls/faust2winunity
++++ b/tools/faust2appls/faust2winunity
+@@ -15,7 +15,7 @@
+ # These files are automatically generated by the "faust2unity" script
+
+ . faustpath
+-. usage.sh
++. faust-usage.sh
+ . faustoptflags
+
+ CXXFLAGS+=" $MYGCCFLAGS" # So that additional CXXFLAGS can be used
+diff --git a/tools/faust2appls/faustremote b/tools/faust2appls/faustremote
+index bcd374c..b51b4f4 100755
+--- a/tools/faust2appls/faustremote
++++ b/tools/faust2appls/faustremote
+@@ -1,6 +1,6 @@
+ #!/bin/bash
+
+-. usage.sh
++. faust-usage.sh
+
+ #USAGE : faustremote <servurl> ==> <targets>
+ #USAGE : faustremote [<servurl>] <platform> <arch> <srcfile> ==> <binary.zip>