aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-11-01 15:02:21 +0100
committerBart Ribbers <bribbers@disroot.org>2021-11-01 15:57:08 +0000
commitf8b616bf6971625cf7e3ff9465d6022ffa26269a (patch)
treed8e3fa3928b9f079778b35b8fb0a435e55aef445
parentb0abb91dfca08c2d8fd293310c8206f8cd645d5a (diff)
downloadaports-f8b616bf6971625cf7e3ff9465d6022ffa26269a.tar.gz
aports-f8b616bf6971625cf7e3ff9465d6022ffa26269a.tar.bz2
aports-f8b616bf6971625cf7e3ff9465d6022ffa26269a.tar.xz
community/nemo-qml-plugin-contacts: upgrade to 0.2.26
-rw-r--r--community/nemo-qml-plugin-contacts/APKBUILD13
-rw-r--r--community/nemo-qml-plugin-contacts/update-api-for-qtpim-5.9.patch36
2 files changed, 17 insertions, 32 deletions
diff --git a/community/nemo-qml-plugin-contacts/APKBUILD b/community/nemo-qml-plugin-contacts/APKBUILD
index 8cd408d02e..daab2c4cc0 100644
--- a/community/nemo-qml-plugin-contacts/APKBUILD
+++ b/community/nemo-qml-plugin-contacts/APKBUILD
@@ -1,10 +1,11 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=nemo-qml-plugin-contacts
-pkgver=0.2.25
+# Can't be updated to a newer version as long as qtcontacts-sqlite isn't updated
+pkgver=0.2.26
pkgrel=0
pkgdesc="Nemo QML contacts plugin"
-url="https://git.sailfishos.org/mer-core/nemo-qml-plugin-contacts"
+url="https://github.com/sailfishos/nemo-qml-plugin-contacts"
arch="all"
license="BSD-3-Clause"
depends="qtcontacts-sqlite"
@@ -18,7 +19,7 @@ makedepends="
qtchooser
qtcontacts-sqlite-dev
"
-source="https://git.sailfishos.org/mer-core/nemo-qml-plugin-contacts/-/archive/$pkgver/nemo-qml-plugin-contacts-$pkgver.tar.gz
+source="https://github.com/sailfishos/nemo-qml-plugin-contacts/archive/$pkgver/nemo-qml-plugin-contacts-$pkgver.tar.gz
update-api-for-qtpim-5.9.patch
"
options="!check" # No tests
@@ -35,5 +36,7 @@ package() {
rm -r "$pkgdir"/opt
}
-sha512sums="42b58989894cbeb33d554af7f3f793642c97bfc73695981ed8681ddd8d998e807b36145ccdea8d6b7bf592f9d73b35282d9e220ca4b761d7c236c51cdb0ca0d1 nemo-qml-plugin-contacts-0.2.25.tar.gz
-4b222f2a0551664d9be96b041424ed8ae904ad405b0e9e2840495c090936dd5fed2ff95a03831fab4e2202eea9792a4cb6660dba3e60b4c426aa2076250e2e02 update-api-for-qtpim-5.9.patch"
+sha512sums="
+a2b05b548fad0e2e6da45e6e74ac75da0d1862c9f9f8d96ff7e1f769340a81deab0d695b150e694e7db47f5148735be4bf15d28fa96218994a2396a1f5f3a09c nemo-qml-plugin-contacts-0.2.26.tar.gz
+cd64ebceaf8adf07bfac0d3bc07017953749bb3b3f726d2bc9698a6a7c0485c725a06287934f7cfa2b15fae65bf6c75d57a756d2b27dc6f2cfa47219017bff15 update-api-for-qtpim-5.9.patch
+"
diff --git a/community/nemo-qml-plugin-contacts/update-api-for-qtpim-5.9.patch b/community/nemo-qml-plugin-contacts/update-api-for-qtpim-5.9.patch
index 4674800adf..dd1c56e405 100644
--- a/community/nemo-qml-plugin-contacts/update-api-for-qtpim-5.9.patch
+++ b/community/nemo-qml-plugin-contacts/update-api-for-qtpim-5.9.patch
@@ -11,52 +11,34 @@ Subject: [PATCH] [nemo-qml-contacts] Update API for QtPim 5.9
4 files changed, 15 insertions(+), 6 deletions(-)
diff --git a/rpm/nemo-qml-plugin-contacts-qt5.spec b/rpm/nemo-qml-plugin-contacts-qt5.spec
-index 55ea2f6..ea6ff5b 100644
+index a6d50db..86c717b 100644
--- a/rpm/nemo-qml-plugin-contacts-qt5.spec
+++ b/rpm/nemo-qml-plugin-contacts-qt5.spec
-@@ -1,7 +1,7 @@
- Name: nemo-qml-plugin-contacts-qt5
-
- Summary: Nemo QML contacts plugin
--Version: 0.2.25
-+Version: 0.2.26
- Release: 1
- Group: System/Libraries
- License: BSD
-@@ -10,7 +10,6 @@ Source0: %{name}-%{version}.tar.bz2
+@@ -12,7 +12,6 @@ Obsoletes: libcontacts-qt5-devel <= 0.2.11
Requires: qtcontacts-sqlite-qt5 >= 0.1.37
BuildRequires: pkgconfig(Qt5Core)
BuildRequires: pkgconfig(Qt5Qml)
-BuildRequires: pkgconfig(Qt5Contacts)
BuildRequires: pkgconfig(Qt5Versit)
BuildRequires: pkgconfig(Qt5Test)
- BuildRequires: pkgconfig(qtcontacts-sqlite-qt5-extensions) >= 0.2.31
-@@ -19,13 +18,17 @@ BuildRequires: pkgconfig(mlocale5)
- BuildRequires: pkgconfig(mlite5)
+ BuildRequires: pkgconfig(qtcontacts-sqlite-qt5-extensions) >= 0.3.0
+@@ -23,6 +22,9 @@ BuildRequires: pkgconfig(accounts-qt5)
+ BuildRequires: libphonenumber-devel
BuildRequires: qt5-qttools-linguist
BuildRequires: qt5-qttools
+#Because pkgconfig QtContacts always return 5.0.0 use packages version
+BuildRequires: qt5-qtpim-contacts-devel >= 5.8
+Requires: qt5-qtpim-contacts >= 5.8
-+
%description
%{summary}.
-
- %package ts-devel
- Summary: Translation source for nemo-qml-plugin-contacts-qt5
--Group: System/Libraries
-+Group: Development/Languages
-
- %description ts-devel
- Translation source for nemo-qml-plugin-contacts-qt5
diff --git a/src/seasideperson.cpp b/src/seasideperson.cpp
-index 77a9048..69c0c6c 100644
+index 49debeb..87589a6 100644
--- a/src/seasideperson.cpp
+++ b/src/seasideperson.cpp
-@@ -53,6 +53,8 @@
- #include <QVersitWriter>
- #include <QVersitContactExporter>
+@@ -58,6 +58,8 @@
+ #include <QFile>
+ #include <QDebug>
+#include <QDebug>
+