aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-08-07 18:23:25 +0300
committerAndy Postnikov <apostnikov@gmail.com>2019-08-07 20:15:01 +0300
commitf8ccbd9fa3c3bf88c8ce2c55f1630bbf95db91d8 (patch)
tree83fde187bb476855f184a210cc3c94aa95a49094
parenteb40603a035d01156e32b73b6a095fbb6f7c7579 (diff)
community/nodejs-current: upgrade to 12.8.0
-rw-r--r--community/nodejs-current/APKBUILD6
-rw-r--r--community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch10
2 files changed, 8 insertions, 8 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index cdddb4bbfb1..66f0ae0d228 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -20,7 +20,7 @@
#
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
-pkgver=12.7.0
+pkgver=12.8.0
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
@@ -93,6 +93,6 @@ package() {
rm "$pkgdir"/usr/bin/npm "$pkgdir"/usr/bin/npx
}
-sha512sums="8d85130f5a08fd63be0da7c23c8848b592e98ac42fbebccd51ed0852598dcb2a015da3b1ab7e8fef2ba0d3fd0d17325d7159137895b52ede5f88adc440db1f7f node-v12.7.0.tar.gz
-7634ae88ec660867361e0d909f3bf038270524f8e399d8a5f46ce63cc0f21529bdf3165246da263f0a848fd10dd3a2c5877a04864f35bc4c77556d3ac4eb6196 dont-run-gyp-files-for-bundled-deps.patch
+sha512sums="fd50243d2cfba75b0ab0e53706f099c60b287b2d02383d0392b466aa03e7bfb5bc4ecd83f482532e1c54bb6aef9f1fe2551902021169baa8e356f06f76bbe64c node-v12.8.0.tar.gz
+3c536776e2ecb5dc677bf711a09418085b3c5e931a6eaf647f47c28e194d5c6dec354d4e7a039a5805b30fc7e83140594851e18d9120f523eec2f93539eac4db dont-run-gyp-files-for-bundled-deps.patch
9f60928b53447f9590c7065bcdbdd4065d10a06e8451531615791a3bd7d14f9114807e5446e0ec00e2cb7a11a277050345e34636b199db2979d7f022b31ffde4 link-with-libatomic-on-mips32.patch"
diff --git a/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
index 25cce3cbb2a..db2ab01c66e 100644
--- a/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
+++ b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
@@ -9,12 +9,12 @@ Node.js 7.2.0
--- a/Makefile
+++ b/Makefile
-@@ -116,7 +116,7 @@
+@@ -141,7 +141,7 @@
echo "'test-code-cache' target is a noop"
out/Makefile: config.gypi common.gypi node.gyp \
-- deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp \
-+ deps/http_parser/http_parser.gyp \
- tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
- tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
+- deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp \
++ deps/http_parser/http_parser.gyp \
+ tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
+ tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
$(PYTHON) tools/gyp_node.py -f make