aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2021-11-16 16:42:38 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2021-11-16 14:58:20 +0100
commitf9af4f00600e8cb0058ff7d3416436b2f773c12d (patch)
tree82b50f703e9f9fc02c1db93ffa56b9c9d2bf9a21
parenta37fb0afd8167cb373e2e3e94133c4659d107b7b (diff)
downloadaports-f9af4f00600e8cb0058ff7d3416436b2f773c12d.tar.gz
aports-f9af4f00600e8cb0058ff7d3416436b2f773c12d.tar.bz2
aports-f9af4f00600e8cb0058ff7d3416436b2f773c12d.tar.xz
community/dnsdist: re-enable -luajit subpackage again
This looks like it was accidentally removed in 9cf0aa8f7bd2f3640a50bc7da4b655fe7c83a90d in this commit the -luajit subpackage is removed entirely instead of just enabling it for aarch64 again. Since the commit only removes the subpackage but not the split function this looks like a mistake to me. This fixes a dependency error (see #13173). See also f774aa10980364a1659d29f3da489f3889c38ca7
-rw-r--r--community/dnsdist/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/dnsdist/APKBUILD b/community/dnsdist/APKBUILD
index 18ccfefbc1..49af6a92d1 100644
--- a/community/dnsdist/APKBUILD
+++ b/community/dnsdist/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Peter van Dijk <peter.van.dijk@powerdns.com>
pkgname=dnsdist
pkgver=1.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="dnsdist is a highly DNS-, DoS-, and abuse-aware loadbalancer."
url="https://dnsdist.org/"
# s390x and mips64 blocked by h2o
@@ -16,7 +16,7 @@ makedepends="boost-dev fstrm-dev libedit-dev libsodium-dev lua$_lua_version-dev
pkgusers="dnsdist"
pkggroups="dnsdist"
install="$pkgname-common.pre-install"
-subpackages="$pkgname-common::noarch $pkgname-doc"
+subpackages="$pkgname-common::noarch $pkgname-doc $pkgname-luajit"
source="https://downloads.powerdns.com/releases/dnsdist-$pkgver.tar.bz2"
[ "$CARCH" = "ppc64le" ] && options="!check" # failing tests