aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2020-12-03 21:25:34 +0200
committerAndy Postnikov <apostnikov@gmail.com>2020-12-03 21:25:34 +0200
commitfae1152c6e57c8177eb63b4925b7341ec8d8ef43 (patch)
tree0346b4eb8cfa44fedf4be7f7869fb1149ccde688
parent2a628eb600531a015ea876c9401d63017b35eb63 (diff)
community/php7-pecl-oauth: modernize
-rw-r--r--community/php7-pecl-oauth/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/community/php7-pecl-oauth/APKBUILD b/community/php7-pecl-oauth/APKBUILD
index ef02b252434..4e614440a14 100644
--- a/community/php7-pecl-oauth/APKBUILD
+++ b/community/php7-pecl-oauth/APKBUILD
@@ -1,19 +1,19 @@
# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
pkgname=php7-pecl-oauth
-_pkgreal=oauth
+_extname=oauth
pkgver=2.0.7
-pkgrel=0
-pkgdesc="OAuth is an authorization protocol built on top of HTTP."
+pkgrel=1
+pkgdesc="PHP 7 extension, OAuth is an authorization protocol built on top of HTTP - PECL"
url="https://pecl.php.net/package/oauth"
arch="all"
license="BSD-3-Clause"
depends="php7-common"
makedepends="php7-dev curl-dev"
checkdepends="php7-openssl php7-pcntl php7-posix"
-source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz
+source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz
pcre.patch"
-builddir="$srcdir"/$_pkgreal-$pkgver
+builddir="$srcdir"/$_extname-$pkgver
provides="php7-oauth=$pkgver-r$pkgrel" # for backward compatibility
replaces="php7-oauth" # for backward compatibility
@@ -30,15 +30,15 @@ check() {
-d extension=$_modules/openssl.so \
-d extension=$_modules/pcntl.so \
-d extension=$_modules/posix.so \
- -d extension=modules/$_pkgreal.so"
+ -d extension=modules/$_extname.so" TESTS==--show-diff
}
package() {
- make INSTALL_ROOT="$pkgdir"/ install
+ make INSTALL_ROOT="$pkgdir" install
local _confdir="$pkgdir"/etc/php7/conf.d
install -d $_confdir
- echo "extension=$_pkgreal.so" > $_confdir/60_$_pkgreal.ini
+ echo "extension=$_extname" > $_confdir/60_$_extname.ini
}
-sha512sums="261bbe6d1c4299f44ce40030b3959e26f2535c70d01b7a4e870d14c84b0a01e68484e61907554d720667fa08a2ec00b7d43cf2f523800c832f02b093e7b6534a oauth-2.0.7.tgz
+sha512sums="261bbe6d1c4299f44ce40030b3959e26f2535c70d01b7a4e870d14c84b0a01e68484e61907554d720667fa08a2ec00b7d43cf2f523800c832f02b093e7b6534a php-pecl-oauth-2.0.7.tgz
68d636032d2f3cb2822ea3121a80256b87a04cc5998c4775174366c6a3392dfe3abc00c84cc50aca5745a32ddd2246af129fe5aa17cc415652c52214a84feef9 pcre.patch"