aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-06-15 15:40:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-15 20:07:18 +0000
commitfd4cd08345ed6937cd015fade5fc0931c09ba224 (patch)
tree1733662062af0ff579decf0ff6b2a8fbebd9f258
parenta5bc29e2fd2d063ea009721a1db08103becf2e7a (diff)
community/perl-unicode-normalize: rebuild against perl 5.26
-rw-r--r--community/perl-unicode-normalize/APKBUILD21
-rw-r--r--community/perl-unicode-normalize/Unicode-Normalize-1.25-Fixes-for-removal-dot-from-INC.patch12
2 files changed, 22 insertions, 11 deletions
diff --git a/community/perl-unicode-normalize/APKBUILD b/community/perl-unicode-normalize/APKBUILD
index 96f682dc7b0..6eee397d591 100644
--- a/community/perl-unicode-normalize/APKBUILD
+++ b/community/perl-unicode-normalize/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-unicode-normalize
_pkgreal=Unicode-Normalize
pkgver=1.25
-pkgrel=2
+pkgrel=3
pkgdesc="Unicode Normalization Forms"
url="http://search.cpan.org/dist/Unicode-Normalize/"
arch="all"
@@ -14,21 +14,21 @@ cpanmakedepends=" "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/K/KH/KHW/$_pkgreal-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/K/KH/KHW/$_pkgreal-$pkgver.tar.gz
+ Unicode-Normalize-1.25-Fixes-for-removal-dot-from-INC.patch
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare || return 1
-
+build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
-build() {
+check() {
cd "$builddir"
- export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make test
}
package() {
@@ -42,6 +42,5 @@ doc() {
replaces="perl-doc"
}
-md5sums="8f25327bbccc33717b7d85433e1083bd Unicode-Normalize-1.25.tar.gz"
-sha256sums="00b33a75d3b356ade2e09391ea2d32fac881671c18b1eb26b9ca31273d5b046c Unicode-Normalize-1.25.tar.gz"
-sha512sums="f28c19e0293cf75cc0aab669ae0a0543f6a1a39e1e50ff32ab37abd8e85efc73e8b9075e581212b6da576ecbf8c0e9ddb7b9b352674aa3a04c77f9aaf4717866 Unicode-Normalize-1.25.tar.gz"
+sha512sums="f28c19e0293cf75cc0aab669ae0a0543f6a1a39e1e50ff32ab37abd8e85efc73e8b9075e581212b6da576ecbf8c0e9ddb7b9b352674aa3a04c77f9aaf4717866 Unicode-Normalize-1.25.tar.gz
+bd1bd5e67d3a09ddd7bf2ec584af2258ab44e64850e480816c2b824fceabe9c926fe795d610c5468c84a8f375c3826fbf7c69b870cdd7719fc6f3a367660e553 Unicode-Normalize-1.25-Fixes-for-removal-dot-from-INC.patch"
diff --git a/community/perl-unicode-normalize/Unicode-Normalize-1.25-Fixes-for-removal-dot-from-INC.patch b/community/perl-unicode-normalize/Unicode-Normalize-1.25-Fixes-for-removal-dot-from-INC.patch
new file mode 100644
index 00000000000..e34e2b19d39
--- /dev/null
+++ b/community/perl-unicode-normalize/Unicode-Normalize-1.25-Fixes-for-removal-dot-from-INC.patch
@@ -0,0 +1,12 @@
+diff -up Unicode-Normalize-1.25/Makefile.PL.orig Unicode-Normalize-1.25/Makefile.PL
+--- Unicode-Normalize-1.25/Makefile.PL.orig 2017-05-12 10:24:13.296305863 +0200
++++ Unicode-Normalize-1.25/Makefile.PL 2017-05-12 10:25:28.275822594 +0200
+@@ -8,7 +8,7 @@ my $mm_ver = ExtUtils::MakeMaker->VERSIO
+ if (-f "Normalize.xs") {
+ print STDERR "Making header files for XS...\n";
+
+- do 'mkheader' or die $@ || "mkheader: $!";
++ do './mkheader' or die $@ || "mkheader: $!";
+
+ $clean = { FILES => 'unfcan.h unfcmb.h unfcmp.h unfcpt.h unfexc.h' };
+ }