aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-02-03 15:36:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-02-03 15:36:28 +0000
commitfdd44fb8b97da25a99cdcae6376aae92d779d11b (patch)
tree0366d10b8da75f3575f3edb8fbfc2077653db169
parent029ebc61d1c4295d7477d0f6ccf1ec97d1d67fee (diff)
main/ethtool: upgrade to 3.18
-rw-r--r--main/ethtool/APKBUILD16
-rw-r--r--main/ethtool/stdint.patch25
2 files changed, 6 insertions, 35 deletions
diff --git a/main/ethtool/APKBUILD b/main/ethtool/APKBUILD
index 0f98f8e38c2..4404d5b8ba9 100644
--- a/main/ethtool/APKBUILD
+++ b/main/ethtool/APKBUILD
@@ -1,15 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ethtool
-pkgver=3.16
+pkgver=3.18
pkgrel=0
pkgdesc="gkernel ethtool"
url="http://sourceforge.net/projects/gkernel/"
arch="all"
license="GPL2"
depends=""
-makedepends=""
-source="http://www.kernel.org/pub/software/network/ethtool/ethtool-$pkgver.tar.xz
- stdint.patch"
+makedepends="linux-headers"
+source="http://www.kernel.org/pub/software/network/ethtool/ethtool-$pkgver.tar.xz"
subpackages="$pkgname-doc"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -38,9 +37,6 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="7eee202accb86104adc8463a36a1a468 ethtool-3.16.tar.xz
-f953365fe8ba94849f72016090d5e892 stdint.patch"
-sha256sums="d6e0dd3fa904c3ad87487c66a4a8fde1ebc4194979ca5755df4b2efb247ca286 ethtool-3.16.tar.xz
-ef1df6825715164bcf9140f8b91ffd9fdc0256a8305c9dc6960ef8e3cfa98042 stdint.patch"
-sha512sums="5f3790872eef14c20b4e1c59e9f318f18811022fa2b1c345699c815acf942e91288bb08d6e7d36d8b4f33101e52c832522d5118146f9e0f5d98cdf2f9c0d0d30 ethtool-3.16.tar.xz
-c8a602dd814d57728ca66b5257d6b9a990b145a783e61edbe5e09d99a1e8f8b111d936f4b369b239a31f86383ea6fd8cef3f7524d993be6e318d817ab534e422 stdint.patch"
+md5sums="fbf1a167b88a5966a2c56a2483af68c6 ethtool-3.18.tar.xz"
+sha256sums="813ffe59fddd2db423c578448b10e33e2e2d4cc2ba780f1f0c603642b20342f6 ethtool-3.18.tar.xz"
+sha512sums="06fba3458c69bd414f5c5edaba006f39e0777614521e5dc37859d1947d3069f7c04f8ea2513f16a930183fb98fc4b6e7cc374a2070787a750673cbf01943eb62 ethtool-3.18.tar.xz"
diff --git a/main/ethtool/stdint.patch b/main/ethtool/stdint.patch
deleted file mode 100644
index cf9ae83c2b2..00000000000
--- a/main/ethtool/stdint.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- ./internal.h.orig
-+++ ./internal.h
-@@ -7,6 +7,7 @@
- #include "ethtool-config.h"
- #endif
- #include <stdio.h>
-+#include <stdint.h>
- #include <stdlib.h>
- #include <string.h>
- #include <sys/types.h>
-@@ -23,10 +24,10 @@
- #endif
-
- typedef unsigned long long u64;
--typedef __uint32_t u32;
--typedef __uint16_t u16;
--typedef __uint8_t u8;
--typedef __int32_t s32;
-+typedef uint32_t u32;
-+typedef uint16_t u16;
-+typedef uint8_t u8;
-+typedef int32_t s32;
-
- #include "ethtool-copy.h"
- #include "net_tstamp-copy.h"