aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAndrew Manison <amanison@byrd-vm.localdomain>2010-04-04 16:51:44 -0400
committerAndrew Manison <amanison@byrd-vm.localdomain>2010-04-04 16:51:44 -0400
commitc9214a0549042005267e97080de0cac812deb8ab (patch)
treefe9ad881f0c93849647ec984a5f920ce45fac594 /Makefile
parent8b35a9ab83a841ab17ead4606f647a3158c274fe (diff)
Changes to package builds to fix missing/changed/broken source archives.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile33
1 files changed, 10 insertions, 23 deletions
diff --git a/Makefile b/Makefile
index 993cc16a1ad..0bfa4e00806 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,10 @@ rootdir := $(shell pwd)
all: main testing non-free unstable
+apkbuilds := $(shell find . -maxdepth 3 -name APKBUILD -print)
+
+all-modules := $(sort $(subst ./,,$(patsubst %/,%,$(dir $(apkbuilds)))))
+
main-modules := $(sort \
$(notdir \
$(patsubst %/,%, \
@@ -57,33 +61,16 @@ unstable:
done
clean:
- for p in $(main-modules) ; \
- do \
- cd $(rootdir)/main/$$p; \
- abuild clean; \
- abuild cleanoldpkg; \
- abuild cleanpkg; \
- abuild cleancache; \
- done
- for p in $(testing-modules) ; \
- do \
- cd $(rootdir)/testing/$$p; \
+ for p in $(all-modules) ; do \
+ cd $(rootdir)/$$p; \
abuild clean; \
- abuild cleanoldpkg; \
abuild cleanpkg; \
- abuild cleancache; \
done
- for p in $(non-free-modules) ; \
- do \
- cd $(rootdir)/non-free/$$p; \
- abuild clean; \
- abuild cleanoldpkg; \
- abuild cleanpkg; \
- abuild cleancache; \
- done
- for p in $(unstable-modules) ; \
+
+distclean:
+ for p in $(all-modules) ; \
do \
- cd $(rootdir)/unstable/$$p; \
+ cd $(rootdir)/$$p; \
abuild clean; \
abuild cleanoldpkg; \
abuild cleanpkg; \