aboutsummaryrefslogtreecommitdiffstats
path: root/community/R/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-08-15 04:40:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-08-15 09:26:13 +0000
commit135fe81ec97aa27e819be7b6a6547820a85e8253 (patch)
tree06859e8001f0dc8d87fc3b4afdefaab4a9f99a0a /community/R/APKBUILD
parentc845169d660e29411dce32518b83a186b4af604d (diff)
community/R: fix locales
fixes #8918 https://stackoverflow.com/questions/44143931/iconvlist-inconsistency-on-alpine-linux
Diffstat (limited to 'community/R/APKBUILD')
-rw-r--r--community/R/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/community/R/APKBUILD b/community/R/APKBUILD
index 44bac3eef2d..7b0f0075bcb 100644
--- a/community/R/APKBUILD
+++ b/community/R/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=R
pkgver=4.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="Language and environment for statistical computing"
url="https://www.r-project.org"
arch="all !mips !mips64"
@@ -86,6 +86,12 @@ package() {
mv "$f" "$pkgdir"/etc/R/ && ln -sf /etc/R/$f $f
done
cd -
+
+ # Fix #8918
+ # R expects iconv -l to return whitespace-separated list of
+ # locales, our returns ', ' separated so it adds a , for every
+ # locale
+ sed -i 's/,//g' "$pkgdir"/usr/lib/R/library/utils/iconvlist
}
mathlib() {