aboutsummaryrefslogtreecommitdiffstats
path: root/community/R/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-06 07:13:20 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-06 07:37:47 -0300
commit1dda7ac2ae9a3a7ce3a692224f528e10899067aa (patch)
tree18c8d5fa7f8760f4ac0e5e33424638a122c3ba42 /community/R/APKBUILD
parentf37358f297ed428cc88ad6e4bf5cd05059ce3c55 (diff)
community/R: upgrade to 3.6.1
Diffstat (limited to 'community/R/APKBUILD')
-rw-r--r--community/R/APKBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/community/R/APKBUILD b/community/R/APKBUILD
index c1ce1f70a88..6682cafeeb8 100644
--- a/community/R/APKBUILD
+++ b/community/R/APKBUILD
@@ -2,12 +2,12 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=R
-pkgver=3.6.0
-pkgrel=1
+pkgver=3.6.1
+pkgrel=0
pkgdesc="Language and environment for statistical computing"
url="https://www.r-project.org"
arch="all"
-license="GPL-2.0 GPL-3 LGPL-2.1"
+license="(GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later"
depends="$pkgname-mathlib"
depends_dev="gcc gfortran icu-dev libjpeg-turbo libpng-dev make openblas-dev>=0.3.0
pcre-dev>=8.10 readline-dev xz-dev zlib-dev bzip2-dev curl-dev>=7.28
@@ -18,14 +18,11 @@ makedepends="$depends_dev cairo-dev libxmu-dev openjdk8-jre-base pango-dev
install="$pkgname.post-install"
subpackages="$pkgname-mathlib $pkgname-dev $pkgname-doc"
source="https://cran.r-project.org/src/base/R-${pkgver%%.*}/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
_rhome="usr/lib/R"
ldpath="/$_rhome/lib"
build() {
- cd "$builddir"
-
# CXXFLAGS is propagated to /etc/R/Makeconf that is read when building
# additional R modules. -D__MUSL__ is needed for some modules like Rcpp.
# htps://github.com/RcppCore/Rcpp/issues/448
@@ -58,8 +55,6 @@ build() {
# TODO: Run provided test suite.
check() {
- cd "$builddir"
-
./bin/R --version
./bin/R --slave --vanilla -e 'print("Hello, world!")'
}
@@ -67,8 +62,6 @@ check() {
package() {
local destdir="$pkgdir/$_rhome"
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
# Install libRmath.so.
@@ -102,4 +95,4 @@ mathlib() {
mv "$pkgdir"/usr/lib/libRmath.so* "$subpkgdir"/usr/lib
}
-sha512sums="b2e17b909b6387abb964492e2e9370f913295ca7ac99bab0e965c43ed3c4635e27468c326fb2bca3c529b03c731b0170d9e777a194ad4d6c5a983c050223d8c8 R-3.6.0.tar.gz"
+sha512sums="fae7d114437c4b5d10fcb2a4265acd707ad2a4810eeb7c11e25caca1d85093a1495c2e13457b4894c1508830ec1b2be95379b7d54007cf3e574c2a9eea28ef80 R-3.6.1.tar.gz"