aboutsummaryrefslogtreecommitdiffstats
path: root/community/abiword/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-01 14:44:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-01 15:22:21 -0300
commit85385006e2acc5ac59420d6cd872fa1f241b5d5f (patch)
tree4ee9ae4209195aecd84e5e0fa81e6d9981290e1a /community/abiword/APKBUILD
parentad44c7816d91061ff10ca977c9365dd5e8ed3932 (diff)
community/abiword: add enchant-2
Diffstat (limited to 'community/abiword/APKBUILD')
-rw-r--r--community/abiword/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/community/abiword/APKBUILD b/community/abiword/APKBUILD
index c00f053d3b2..6eed2183dd7 100644
--- a/community/abiword/APKBUILD
+++ b/community/abiword/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
pkgver=3.0.4
-pkgrel=2
+pkgrel=3
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
arch="all !s390x"
options="!check" # Test suite requires valgrind, etc
license="GPL-2.0-or-later"
-makedepends="gtk+3.0-dev readline-dev libgsf-dev fribidi-dev wv-dev
+makedepends="gtk+3.0-dev readline-dev libgsf-dev enchant2-dev fribidi-dev wv-dev
popt-dev libjpeg-turbo-dev librsvg-dev bzip2-dev goffice-dev pcre-dev
libxslt-dev perl"
@@ -31,6 +31,14 @@ done
source="http://www.abisource.com/downloads/abiword/$pkgver/source/abiword-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+
+ sed -i 's/enchant >=/enchant-2 >=/' configure.ac
+
+ autoreconf -fi
+}
+
build() {
./configure \
--build=$CBUILD \