aboutsummaryrefslogtreecommitdiffstats
path: root/community/abiword/APKBUILD
diff options
context:
space:
mode:
authorCág <ca6c@bitmessage.ch>2018-03-22 15:03:49 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-03-26 12:53:01 +0000
commit91c113d81028dd86e0c4a60845a48236d168fcd9 (patch)
treed745fc0ae8dd27fdcea401d2434e37b1b4aaed25 /community/abiword/APKBUILD
parentc638ae95d51c6cdf2077c78c4cfd85fe46e0ffaf (diff)
community/abiword: fix plugins
Diffstat (limited to 'community/abiword/APKBUILD')
-rw-r--r--community/abiword/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/community/abiword/APKBUILD b/community/abiword/APKBUILD
index f4d3574d937..7ec1b1edc48 100644
--- a/community/abiword/APKBUILD
+++ b/community/abiword/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
pkgver=3.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
arch="all"
options="!check" # Test suite requires valgrind, etc
license="GPL-2.0-or-later"
-makedepends="gtk+3.0-dev libgsf-dev enchant-dev fribidi-dev wv-dev
+makedepends="gtk+3.0-dev readline-dev libgsf-dev enchant-dev fribidi-dev wv-dev
popt-dev libjpeg-turbo-dev librsvg-dev bzip2-dev goffice-dev pcre-dev
libxslt-dev"
@@ -19,10 +19,10 @@ makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-plugins"
-_plugins="applix babelfish bmp clarisworks collab docbook eml epub
- freetranslation garble gdict gimp google hancom hrtext iscii kword
- latex loadbindings mht mif mswrite openwriter openxml opml paint
- passepartout pdb pdf presentation s5 sdw t602 urldict wikipedia wml
+_plugins="applix babelfish bmp clarisworks collab docbook command eml epub \
+ freetranslation garble gdict gimp google hancom hrtext iscii kword \
+ latex loadbindings mht mif mswrite openwriter openxml opml paint \
+ passepartout pdb pdf presentation s5 sdw t602 urldict wikipedia wml \
xslfo"
for _i in $_plugins; do
@@ -42,7 +42,7 @@ build() {
--prefix=/usr \
--enable-shared \
--disable-static \
- --enable-plugins
+ --enable-plugins="$_plugins"
make
}