aboutsummaryrefslogtreecommitdiffstats
path: root/community/apk-polkit-rs/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-09-07 21:56:54 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-09-17 08:42:53 +0000
commitb9f9559044c5816b506bc2dd6c91d4d2cc4b4313 (patch)
tree146b75c97549ba099f69d1f8b7447f23ec58c004 /community/apk-polkit-rs/APKBUILD
parent1f8ca269634e5e2de3e8cd470e732fe0300cf5f5 (diff)
community/apk-polkit-rs: new aport
https://gitlab.alpinelinux.org/Cogitri/apk-polkit apk-polkit-rs exposes a DBus API for APK, the Alpine Package Keeper
Diffstat (limited to 'community/apk-polkit-rs/APKBUILD')
-rw-r--r--community/apk-polkit-rs/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/apk-polkit-rs/APKBUILD b/community/apk-polkit-rs/APKBUILD
new file mode 100644
index 00000000000..0ee4839045e
--- /dev/null
+++ b/community/apk-polkit-rs/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=apk-polkit-rs
+pkgver=0.90.0
+_gitlabsha=d8e71cde795441ce174051f87a443777
+pkgrel=0
+pkgdesc="apk-polkit-rs exposes a DBus API for APK, the Alpine Package Keeper"
+url="https://gitlab.alpinelinux.org/Cogitri/apk-polkit"
+arch="x86_64 armv7 armhf aarch64 x86 ppc64le"
+license="GPL-3.0-or-later"
+depends="polkit"
+makedepends="meson cargo polkit-dev glib-dev lua5.3-lzlib lua5.3
+ openssl-dev clang-dev"
+checkdepends="appstream-glib bash apk-tools"
+subpackages="$pkgname-dev $pkgname-dbg $pkgname-lang"
+source="https://gitlab.alpinelinux.org/Cogitri/apk-polkit-rs/uploads/$_gitlabsha/apk-polkit-rs-$pkgver.tar.xz"
+
+build() {
+ abuild-meson . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
+}
+
+check() {
+ meson test --no-rebuild -v -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ rm "$pkgdir"/usr/lib/libapk.a
+}
+
+sha512sums="2171d5ab6cf0cca6b5fbd2edab0386e3b82d5516987a6958987004da8518ba489eb8ab16d73c79412de7ff8130eff80a7f1c4a1be45d3e3e8fd9f74f871ef6e3 apk-polkit-rs-0.90.0.tar.xz"