aboutsummaryrefslogtreecommitdiffstats
path: root/community/appstream-glib/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-09-01 00:10:10 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-09-07 11:37:00 +0200
commit1aed45575d5d0b4d99228449638d914233840c62 (patch)
tree28e43d17634a5d80d0ec27d0a1b8af600b004344 /community/appstream-glib/APKBUILD
parentb4643f91501aee3b7b53495f390507822914f56e (diff)
community/appstream-glib: use abuild-meson & meson compile/test/install
Diffstat (limited to 'community/appstream-glib/APKBUILD')
-rw-r--r--community/appstream-glib/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/community/appstream-glib/APKBUILD b/community/appstream-glib/APKBUILD
index af48c7e05c9..b55ff2c4fdb 100644
--- a/community/appstream-glib/APKBUILD
+++ b/community/appstream-glib/APKBUILD
@@ -34,9 +34,7 @@ source="https://people.freedesktop.org/~hughsient/appstream-glib/releases/appstr
options="!check" # selftest fails due to updated metadata at upstream
build() {
- meson \
- --prefix=/usr \
- --buildtype=plain \
+ abuild-meson \
-Ddep11=true \
-Dbuilder=true \
-Drpm=false \
@@ -47,7 +45,7 @@ build() {
-Dgtk-doc=false \
-Dintrospection=true \
output
- ninja -C output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
@@ -57,11 +55,11 @@ check() {
return 0
;;
esac
- ninja -C output test
+ meson test --no-rebuild -v -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
# Remove installed tests
rm -rf "$pkgdir"/usr/share/installed-tests/appstream-glib