aboutsummaryrefslogtreecommitdiffstats
path: root/community/archivemount
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-28 07:41:15 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-06-28 13:55:54 +0000
commitc3bb6cb1e65df26d26fdc0b4ba7e8aa75a439ed2 (patch)
treebbb385acd4028614cd1a3be0d766067e71fa84ff /community/archivemount
parent76deacce283bcc7a3ff28ca03e83965a74f82472 (diff)
testing/[various]: move more packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. aha archivemount bannergrab bmon py-gpiozera py-rpizero py-skywriter-hat remind
Diffstat (limited to 'community/archivemount')
-rw-r--r--community/archivemount/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/archivemount/APKBUILD b/community/archivemount/APKBUILD
new file mode 100644
index 00000000000..dbb08a57c17
--- /dev/null
+++ b/community/archivemount/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=archivemount
+pkgver=0.8.3
+pkgrel=0
+pkgdesc="FUSE based filesystem for mounting compressed archives"
+url="http://www.cybernoia.de/software/archivemount/"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev fuse-dev libarchive-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.cybernoia.de/software/archivemount/archivemount-$pkgver.tar.gz"
+
+_builddir="$srcdir"/archivemount-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="a8c890e3fc315b07c7e85ad73a4b4760 archivemount-0.8.3.tar.gz"
+sha256sums="e78899a8b7c9cb43fa4526d08c54a9e171475c00bf095770b8779a33e37661ff archivemount-0.8.3.tar.gz"
+sha512sums="f0d50cdce44a0ee57f0d3a32cb37af4159a7400e47a8c61360c9c0c1be6fdbe98d2aa1cc530b3a71fe70e4f550ea5ed431204d738931dca757135677e1984733 archivemount-0.8.3.tar.gz"